summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-26 15:10:58 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-27 21:00:20 +0200
commit3af4117d918c855770200a2940b144809b14aa4c (patch)
tree55ee38d5677f7f9d9a5e563ab78361fb008659bc /dev-qt/qtimageformats
parentprofiles: Mask Qt 5.11.1 for testing (diff)
downloadgentoo-3af4117d918c855770200a2940b144809b14aa4c.tar.gz
gentoo-3af4117d918c855770200a2940b144809b14aa4c.tar.bz2
gentoo-3af4117d918c855770200a2940b144809b14aa4c.zip
dev-qt: Add Qt 5.11.1 (masked)
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-qt/qtimageformats')
-rw-r--r--dev-qt/qtimageformats/Manifest1
-rw-r--r--dev-qt/qtimageformats/qtimageformats-5.11.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-qt/qtimageformats/Manifest b/dev-qt/qtimageformats/Manifest
index 347eeae9a62b..4f59bf7ac37c 100644
--- a/dev-qt/qtimageformats/Manifest
+++ b/dev-qt/qtimageformats/Manifest
@@ -1,3 +1,4 @@
DIST qtimageformats-everywhere-src-5.11.0-rc2.tar.xz 2188164 BLAKE2B 8e7d59ea7994d5d8d1dae80c1e9d8f07d91b1da550d87e19a45ec1944f41cd68d417c2673dce33d602fb2c6684737437e0c5bbfd4fdc49fb5a8a5b2e66442cf3 SHA512 775335f3cb39edf953379d9effdb73b62254a0837891ec4a1838b2113857f9087098495eb808ffa24e2e8b7e799199f6b61ae52aa14e2d95f5dff860c7a78653
+DIST qtimageformats-everywhere-src-5.11.1.tar.xz 2191408 BLAKE2B 7a01c6c607cdb02471c289b71151d8fcba2047778c6d499a54dd66d125a7dac29b944b2b722aa8bf8667f453e92edba20adf10cfe6c580af7ac42c41aebd3a8c SHA512 527bd6d324904d1c7c6d931fe96bfa43575a904d2b94cbda3129c4a883fb79b9bdf6f009b41d2747e8aec2c410a2b23bfa0e94fc4eea698d54a0878bc934514d
DIST qtimageformats-opensource-src-5.9.4.tar.xz 2106852 BLAKE2B 31f0f5d6c545f04b2be4bd657acce63adb15a45d4b0471b249e39063ae47635a8c5338f44cc0af88ca0c960d399384a911add12f7cd2815c808ddc28d7f5e924 SHA512 91ebe0d4cc67b3d3c55da4dd5d08028f7046819fdc4034ed0ddec075443ebe3775690856a7aa7704ee3ad8893948f79bdc72467fdfea6a0a8ce6fb16b3f5ab5a
DIST qtimageformats-opensource-src-5.9.6.tar.xz 2107828 BLAKE2B bbea8e01d7c7e4510c35a6322f72c9b531daa844745e5ea007bdc516f60bf72de48a5aa18e7209b6b25da189362b4db8be5fa3d4e8addc90f407a3879b7cc69d SHA512 c6470c1486ae9b0bc3c846c1de6ffa294810aca20ca90d9d5f40a257a7e339ff58aeafd5f76324e6939d71889044eebc48b8b001f2027dbabd15f7eeb8d8bdf8
diff --git a/dev-qt/qtimageformats/qtimageformats-5.11.1.ebuild b/dev-qt/qtimageformats/qtimageformats-5.11.1.ebuild
new file mode 100644
index 000000000000..5b10805b2ac2
--- /dev/null
+++ b/dev-qt/qtimageformats/qtimageformats-5.11.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Additional format plugins for the Qt image I/O system"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
+fi
+
+IUSE="jpeg2k mng"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}
+ media-libs/libwebp:=
+ media-libs/tiff:0
+ jpeg2k? ( media-libs/jasper:= )
+ mng? ( media-libs/libmng:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ qt_use_compile_test jpeg2k jasper
+ qt_use_compile_test mng libmng
+ qt5-build_src_configure
+}