summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-13 13:09:53 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-13 13:09:53 +0100
commitf54ae630a8d491a3028f19cbff8ba93577b802cb (patch)
treeecef62abc8c3e2e40dd72468527a88b8962524c7 /dev-ros/hector_imu_attitude_to_tf
parentdev-ros/hector_geotiff: Bump to 0.4.0. (diff)
downloadgentoo-f54ae630a8d491a3028f19cbff8ba93577b802cb.tar.gz
gentoo-f54ae630a8d491a3028f19cbff8ba93577b802cb.tar.bz2
gentoo-f54ae630a8d491a3028f19cbff8ba93577b802cb.zip
dev-ros/hector_imu_attitude_to_tf: Bump to 0.4.0.
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/hector_imu_attitude_to_tf')
-rw-r--r--dev-ros/hector_imu_attitude_to_tf/Manifest1
-rw-r--r--dev-ros/hector_imu_attitude_to_tf/hector_imu_attitude_to_tf-0.4.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/hector_imu_attitude_to_tf/Manifest b/dev-ros/hector_imu_attitude_to_tf/Manifest
index 1f7882454e47..dc0978f6c2bf 100644
--- a/dev-ros/hector_imu_attitude_to_tf/Manifest
+++ b/dev-ros/hector_imu_attitude_to_tf/Manifest
@@ -1 +1,2 @@
DIST hector_slam-0.3.5.tar.gz 66002 BLAKE2B 6e370fedf49b450cd3dec77eb7a197cc13796d787c41a72d5bdf918661728e96ff9e388ab1f2c5cf64c13ff6e94e058fc4c8ba176307b63cc51b892c0183dd54 SHA512 7f61c6b0607295b6b96fb9cadbaafc7531013a0d7cfaab19630c14ac52cde8920376a57041577d2c9945130200ce5912ba331dd1e3d0f41297a928a34a45dfa1
+DIST hector_slam-0.4.0.tar.gz 66634 BLAKE2B 7d4798d4c247268d01a51a8d796441807f9243d074ccd4584b759da91779d8a565de28f18bd0d7d59b71e2710c71b39d7fafd4de5de8c6fbd8d3ca453788998b SHA512 1951a31fa02b042ce167367d94ab8a8f7481dc1eb3f6dc1c0f248f552ae8cf312af1ba9519eeefd3b24bed9b593a60b0734a23de9214ca35c48f7cc33ab5d437
diff --git a/dev-ros/hector_imu_attitude_to_tf/hector_imu_attitude_to_tf-0.4.0.ebuild b/dev-ros/hector_imu_attitude_to_tf/hector_imu_attitude_to_tf-0.4.0.ebuild
new file mode 100644
index 000000000000..ff3bcfe62c69
--- /dev/null
+++ b/dev-ros/hector_imu_attitude_to_tf/hector_imu_attitude_to_tf-0.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Publish the roll/pitch attitude angles reported via a imu message to tf"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"