summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-19 11:26:29 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-19 11:30:04 +0200
commit454aa0409ad7d5578776c1626fded54c150f9004 (patch)
tree0640c8d5dec8659c95402302fd657f333cfeebf3 /dev-ros/kdl_parser_py/kdl_parser_py-1.12.2.ebuild
parentdev-ros/kdl_parser: Bump to 1.12.2. (diff)
downloadgentoo-454aa0409ad7d5578776c1626fded54c150f9004.tar.gz
gentoo-454aa0409ad7d5578776c1626fded54c150f9004.tar.bz2
gentoo-454aa0409ad7d5578776c1626fded54c150f9004.zip
dev-ros/kdl_parser_py: Bump to 1.12.2.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ros/kdl_parser_py/kdl_parser_py-1.12.2.ebuild')
-rw-r--r--dev-ros/kdl_parser_py/kdl_parser_py-1.12.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/kdl_parser_py/kdl_parser_py-1.12.2.ebuild b/dev-ros/kdl_parser_py/kdl_parser_py-1.12.2.ebuild
new file mode 100644
index 000000000000..e6c1e39c0b56
--- /dev/null
+++ b/dev-ros/kdl_parser_py/kdl_parser_py-1.12.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/robot_model"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Python tools to construct a KDL tree from an XML robot representation in URDF"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/urdf[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"