summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-11 16:29:32 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-11 17:12:24 +0100
commitfed65f091e3e3dd8afc7a6077fab56482c2d4e0d (patch)
tree506b750150e0b13c3a188a38981436112c651fe0 /dev-ros/move_slow_and_clear/move_slow_and_clear-1.16.3.ebuild
parentdev-ros/move_base: Bump to 1.16.3. (diff)
downloadgentoo-fed65f091e3e3dd8afc7a6077fab56482c2d4e0d.tar.gz
gentoo-fed65f091e3e3dd8afc7a6077fab56482c2d4e0d.tar.bz2
gentoo-fed65f091e3e3dd8afc7a6077fab56482c2d4e0d.zip
dev-ros/move_slow_and_clear: Bump to 1.16.3.
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/move_slow_and_clear/move_slow_and_clear-1.16.3.ebuild')
-rw-r--r--dev-ros/move_slow_and_clear/move_slow_and_clear-1.16.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/move_slow_and_clear/move_slow_and_clear-1.16.3.ebuild b/dev-ros/move_slow_and_clear/move_slow_and_clear-1.16.3.ebuild
new file mode 100644
index 000000000000..bdd963c4a8b5
--- /dev/null
+++ b/dev-ros/move_slow_and_clear/move_slow_and_clear-1.16.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Move slow and clear"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/costmap_2d-1.16
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_core
+ dev-ros/pluginlib
+ dev-ros/roscpp
+
+ dev-libs/boost:=[threads]
+ dev-cpp/eigen:3
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+
+"