summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-14 11:15:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-14 11:16:55 +0200
commit21e668bf18d42511df10864cc0b0a3e06ff1511d (patch)
tree1b96151ce6970ee101d325677cbf153766e75759 /dev-ros/qt_gui_cpp
parentx11-misc/xlockmore: Version 5.66_alpha12 (diff)
downloadgentoo-21e668bf18d42511df10864cc0b0a3e06ff1511d.tar.gz
gentoo-21e668bf18d42511df10864cc0b0a3e06ff1511d.tar.bz2
gentoo-21e668bf18d42511df10864cc0b0a3e06ff1511d.zip
dev-ros/qt_gui_cpp: fix rpaths patch
Closes: https://bugs.gentoo.org/748699 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/qt_gui_cpp')
-rw-r--r--dev-ros/qt_gui_cpp/files/rpaths.patch6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-ros/qt_gui_cpp/files/rpaths.patch b/dev-ros/qt_gui_cpp/files/rpaths.patch
index 7f95b9e938a9..313e3edcb72a 100644
--- a/dev-ros/qt_gui_cpp/files/rpaths.patch
+++ b/dev-ros/qt_gui_cpp/files/rpaths.patch
@@ -2,12 +2,14 @@ Index: qt_gui_cpp/src/qt_gui_cpp_sip/CMakeLists.txt
===================================================================
--- qt_gui_cpp.orig/src/qt_gui_cpp_sip/CMakeLists.txt
+++ qt_gui_cpp/src/qt_gui_cpp_sip/CMakeLists.txt
-@@ -29,7 +29,7 @@ set(qt_gui_cpp_sip_DEPENDENT_FILES
+@@ -29,8 +29,8 @@ set(qt_gui_cpp_sip_DEPENDENT_FILES
# maintain context for different named target
set(qt_gui_cpp_sip_INCLUDE_DIRS ${qt_gui_cpp_INCLUDE_DIRS} "${CMAKE_CURRENT_SOURCE_DIR}/../../include" ${catkin_INCLUDE_DIRS})
set(qt_gui_cpp_sip_LIBRARIES ${qt_gui_cpp_LIBRARIES} ${PROJECT_NAME} ${catkin_LIBRARIES} ${Boost_LIBRARIES})
-set(qt_gui_cpp_sip_LIBRARY_DIRS ${qt_gui_cpp_LIBRARY_DIRS} ${CATKIN_DEVEL_PREFIX}/${CMAKE_INSTALL_LIBDIR})
+-set(qt_gui_cpp_sip_LDFLAGS_OTHER ${qt_gui_cpp_LDFLAGS_OTHER})
+set(qt_gui_cpp_sip_LIBRARY_DIRS ${qt_gui_cpp_LIBRARY_DIRS})
- set(qt_gui_cpp_sip_LDFLAGS_OTHER ${qt_gui_cpp_LDFLAGS_OTHER})
++set(qt_gui_cpp_sip_LDFLAGS_OTHER ${qt_gui_cpp_LDFLAGS_OTHER} -L${CATKIN_DEVEL_PREFIX}/${CMAKE_INSTALL_LIBDIR})
find_package(python_qt_binding REQUIRED)
+ include(${python_qt_binding_EXTRAS_DIR}/sip_helper.cmake)