summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-28 16:57:29 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-28 21:13:16 +0100
commitc3cb472d7a1bccd8c1223a030741d1667ac5032f (patch)
treee6176686e75a54f9e1f448248a9bd650b6693c69 /dev-ros/qt_gui_py_common
parentdev-ros/qt_gui_cpp: Bump to 0.3.4. (diff)
downloadgentoo-c3cb472d7a1bccd8c1223a030741d1667ac5032f.tar.gz
gentoo-c3cb472d7a1bccd8c1223a030741d1667ac5032f.tar.bz2
gentoo-c3cb472d7a1bccd8c1223a030741d1667ac5032f.zip
dev-ros/qt_gui_py_common: Bump to 0.3.4.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/qt_gui_py_common')
-rw-r--r--dev-ros/qt_gui_py_common/Manifest1
-rw-r--r--dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.4.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/qt_gui_py_common/Manifest b/dev-ros/qt_gui_py_common/Manifest
index 4bc2c51cec3f..399e6ad3a90e 100644
--- a/dev-ros/qt_gui_py_common/Manifest
+++ b/dev-ros/qt_gui_py_common/Manifest
@@ -4,3 +4,4 @@ DIST qt_gui_core-0.3.0.tar.gz 86904 SHA256 f785ad2ffcee822edaf8f8baef8f440d3c596
DIST qt_gui_core-0.3.1.tar.gz 87236 SHA256 99ec592081fbc68d263e85ad1134ebf95019f23a4b116b6f0c8ba13764ab3338 SHA512 f209c257fe3f8bf10e285109e6d6a88e2c8f2d6bfdae82bf3177b94f0b0a74ac26585a1b688d37d6db828847f82b9a5d3c362847bedf41db8aa86a2bc9738c3c WHIRLPOOL 23e82cacdf531a27c5a0b8c5296722b87671a2345db1ed6571d4d8708289a9580db25e5a695dc3fc033aa16fb8c70e1934190549698955cd168021bc689ee123
DIST qt_gui_core-0.3.2.tar.gz 87326 SHA256 678e60f413ad455577ce0e76fa34f2603d0f713023a59fb8c4edee3e753489d5 SHA512 9a3e5c395a49efc0cbd747b35898e5931155b9e22f4789cc111cfb28866db4589b3b7fbd8b32cb8d64ade568dd5a9eb4ee4b24f7b7f60dcf5aabc4a380b5c180 WHIRLPOOL 0fe0af5b79ecf27259212b4ccf3f839d6841775b859674619119dfd97de5a3ae5ac337b0e0c92a6a55b02c6905f21c12d27ecf75aef62c320dd05a1f34e611f4
DIST qt_gui_core-0.3.3.tar.gz 87422 SHA256 fc1bf4dfb3d357b38263d36023ee7b55a1799dfa437513ac51041c993e9cecd4 SHA512 5f2906e412b35b6edc9ba8792272b3d733574deda955279327e392ee3b0f55bb01a08607a25632fda43112842743fdd1432874fbf090f6b1404604c329b7dc3a WHIRLPOOL 6856cb3f58d6e68f1b3081ae4f2529f701a355fa5b0698f3191adc341da38fa3a47f17cd4cab459689e522aa7c4a117b0c86c62f39072711eb240234ee67dfe6
+DIST qt_gui_core-0.3.4.tar.gz 87974 SHA256 09da32698c087a73bbf0dae2ce3b9f1d19beb5f56e15d2fd08009260589e27ef SHA512 794b0ea8b92cdbb748282ef48dcb41f24f3b83dd8ad92e8dc895d45ed085b9838b2ca4a5dc43284971d33b7ac40c86ca578fe042d71e0c9d1903cdfb561507af WHIRLPOOL 98b36b798b7dc57e88a5b59586015919c2f1d902dbde9352562237ec6cb6bb27d3fef296da1547949244b2deb0dc2e18a858ef2bb5021af1d64d76688f0b5a71
diff --git a/dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.4.ebuild b/dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.4.ebuild
new file mode 100644
index 000000000000..9d192b21b981
--- /dev/null
+++ b/dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Common functionality for ROS RQT GUI plugins written in Python"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"