summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-09-13 11:24:03 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-09-13 13:24:03 +0200
commitaade5fe55bc0c05179f77ad9b4bc7a9975a6c002 (patch)
tree8b28afe06325b060319ca1d24e35483576d8c306 /dev-ros/rosapi/rosapi-0.8.3.ebuild
parentdev-util/drone: Version bump to 0.8.0_rc5 (diff)
downloadgentoo-aade5fe55bc0c05179f77ad9b4bc7a9975a6c002.tar.gz
gentoo-aade5fe55bc0c05179f77ad9b4bc7a9975a6c002.tar.bz2
gentoo-aade5fe55bc0c05179f77ad9b4bc7a9975a6c002.zip
dev-ros/rosapi: Bump to 0.8.3.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-ros/rosapi/rosapi-0.8.3.ebuild')
-rw-r--r--dev-ros/rosapi/rosapi-0.8.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rosapi/rosapi-0.8.3.ebuild b/dev-ros/rosapi/rosapi-0.8.3.ebuild
new file mode 100644
index 000000000000..348d9a4fa5f0
--- /dev/null
+++ b/dev-ros/rosapi/rosapi-0.8.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/RobotWebTools/rosbridge_suite"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides service calls for getting ros meta-information, like list of topics, services, params, etc."
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rosbridge_library[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"