summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-02-09 11:00:43 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-02-09 12:39:05 +0100
commit056e7393e7faa58e0b1aa452df5e72bc7ba5b719 (patch)
tree199baf0b49454cc27d069774e05be81f7469bac6 /dev-ros/rosservice/rosservice-1.13.6.ebuild
parentdev-ros/rosparam: Bump to 1.13.6. (diff)
downloadgentoo-056e7393e7faa58e0b1aa452df5e72bc7ba5b719.tar.gz
gentoo-056e7393e7faa58e0b1aa452df5e72bc7ba5b719.tar.bz2
gentoo-056e7393e7faa58e0b1aa452df5e72bc7ba5b719.zip
dev-ros/rosservice: Bump to 1.13.6.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ros/rosservice/rosservice-1.13.6.ebuild')
-rw-r--r--dev-ros/rosservice/rosservice-1.13.6.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rosservice/rosservice-1.13.6.ebuild b/dev-ros/rosservice/rosservice-1.13.6.ebuild
new file mode 100644
index 000000000000..5fd9906789c0
--- /dev/null
+++ b/dev-ros/rosservice/rosservice-1.13.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for listing and querying ROS Services"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosmsg[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"