summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-02 11:29:09 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-02 11:33:29 +0200
commit41e70f42fde29f7dd02a0d47603876e16a5d773d (patch)
tree53a1c422f8ca82a1087e085e63defb3d5eeeb145 /dev-ros/rqt_runtime_monitor
parentdev-ros/rqt_runtime_monitor: remove old (diff)
downloadgentoo-41e70f42fde29f7dd02a0d47603876e16a5d773d.tar.gz
gentoo-41e70f42fde29f7dd02a0d47603876e16a5d773d.tar.bz2
gentoo-41e70f42fde29f7dd02a0d47603876e16a5d773d.zip
dev-ros/rqt_runtime_monitor: bump to 0.5.7 and update to split repos
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/rqt_runtime_monitor')
-rw-r--r--dev-ros/rqt_runtime_monitor/Manifest1
-rw-r--r--dev-ros/rqt_runtime_monitor/metadata.xml2
-rw-r--r--dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.7.ebuild25
-rw-r--r--dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-9999.ebuild5
4 files changed, 29 insertions, 4 deletions
diff --git a/dev-ros/rqt_runtime_monitor/Manifest b/dev-ros/rqt_runtime_monitor/Manifest
index bb0da5c3c13b..130058479be5 100644
--- a/dev-ros/rqt_runtime_monitor/Manifest
+++ b/dev-ros/rqt_runtime_monitor/Manifest
@@ -1 +1,2 @@
DIST rqt_robot_plugins-0.5.6.tar.gz 2107696 SHA256 d5f1b509df54b253d3b2952560e8dc5e764c3259b0e9dcff08541e27ac9fed71 SHA512 871f660e22afafd510e34984b94d2530bc3314db194c06ff458430e15b1183a60147289e9544a5fb070665a3c83034cbcccefe2f820e62f091c3bbc0edfd0a51 WHIRLPOOL a90882b1e762f5e53b7ce7ff92695ba8eb63242b53304a08c928f2667ceb206cfda72e64d81b73d1d951e6b92cb5f16327528846f6b54e28b2acaf898424a664
+DIST rqt_runtime_monitor-0.5.7.tar.gz 6804 SHA256 48f32cfce4c395f15d7de22d842f93f97fceee72dffe0576b9b8f0ae67b131a0 SHA512 9ef7fcb3678cde54e9c6484d9fff9b03000f730100ab64edeb5a70bd412970c43a73ef62d14b8ff047ccf9bce23535a30d3551e36074e64618fd8256ac515206 WHIRLPOOL f584307d0c6c9259df46452844b13413e994becaa7afefc959d7719e593d625da243e2bb961a5eab223362611b881b3bd1efcb28eb09d487f882ac43a7b22415
diff --git a/dev-ros/rqt_runtime_monitor/metadata.xml b/dev-ros/rqt_runtime_monitor/metadata.xml
index 70d1993e2855..a83804b3e379 100644
--- a/dev-ros/rqt_runtime_monitor/metadata.xml
+++ b/dev-ros/rqt_runtime_monitor/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo ROS Project</name>
</maintainer>
<upstream>
- <remote-id type="github">ros-visualization/rqt_robot_plugins</remote-id>
+ <remote-id type="github">ros-visualization/rqt_runtime_monitor</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.7.ebuild b/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.7.ebuild
new file mode 100644
index 000000000000..6661912b0eac
--- /dev/null
+++ b/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_runtime_monitor"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin viewing DiagnosticsArray messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-9999.ebuild b/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-9999.ebuild
index 226133f0b97c..6661912b0eac 100644
--- a/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-9999.ebuild
+++ b/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
KEYWORDS="~amd64"
-ROS_REPO_URI="https://github.com/ros-visualization/rqt_robot_plugins"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_runtime_monitor"
PYTHON_COMPAT=( python2_7 )
-ROS_SUBDIR=${PN}
inherit ros-catkin