summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-08 18:28:51 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-08 19:30:03 +0200
commit0209821988e09a020c4b92496918fbe689645749 (patch)
tree9d4098410f270729dcf2606c5ea897e44621d872 /dev-ros/test_rosmaster
parentdev-ros/test_roslib_comm: Bump to 1.15.7. (diff)
downloadgentoo-0209821988e09a020c4b92496918fbe689645749.tar.gz
gentoo-0209821988e09a020c4b92496918fbe689645749.tar.bz2
gentoo-0209821988e09a020c4b92496918fbe689645749.zip
dev-ros/test_rosmaster: Bump to 1.15.7.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_rosmaster')
-rw-r--r--dev-ros/test_rosmaster/Manifest1
-rw-r--r--dev-ros/test_rosmaster/test_rosmaster-1.15.7.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/test_rosmaster/Manifest b/dev-ros/test_rosmaster/Manifest
index 61884545d536..e7119a998e05 100644
--- a/dev-ros/test_rosmaster/Manifest
+++ b/dev-ros/test_rosmaster/Manifest
@@ -1,2 +1,3 @@
DIST ros_comm-1.14.3.tar.gz 1045287 BLAKE2B c079983aa730e70028d1bf2c365d01d99ce09ced0c0f6443b18f9d0fb83715f6af4b313d6db4eb99dcc10052c81fa3e6560e7b3591b2fbe14b9ec20fac24babe SHA512 52df24f10f476697ee6fa340da354b45431f35018a25e2674dc9306f175929a4b0368753503ea143f87aeb4945a2e67c37f83d833f54b53f9a76a81022c280a3
DIST ros_comm-1.15.4.tar.gz 1071246 BLAKE2B 57867c192bfd48f3a0534762808c668031081a6155510879e68f9618226b9c5eff0d5fc9ec0e7ec8d0cc1f0d74794a4e55151036275ae6fc5bb613cc42137ddc SHA512 f92233cbf5ee97832023545730d3e756dfa08507072c074ac3e0763db1c2c2ab9fcbb0c90995a0c5d43f0ddc2ee528c185173a664b19abe4f8159aa3f3cb20dc
+DIST ros_comm-1.15.7.tar.gz 1080092 BLAKE2B d5c0dd1f54eac7aa11be21bbc680f85f988cc9328382c0c675b7d5986e888be603ed82affa5f51a270974d07044debe3ecf86f5647fd59cb29e8e791a227feb9 SHA512 67dc100e8ed03a25ea228cc7d456ec2203324098f9e11c9a249299df73bfc34efc75b1221c0fb6fceb38fece627f1dc5f2c23be93c9a1c85b1075784a45ff20e
diff --git a/dev-ros/test_rosmaster/test_rosmaster-1.15.7.ebuild b/dev-ros/test_rosmaster/test_rosmaster-1.15.7.ebuild
new file mode 100644
index 000000000000..ea88573de821
--- /dev/null
+++ b/dev-ros/test_rosmaster/test_rosmaster-1.15.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosmaster"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/roslib[${PYTHON_USEDEP}] )
+"
+
+mycatkincmakeargs=( "-DCATKIN_ENABLE_TESTING=ON" )
+
+src_install() {
+ ros-catkin_src_install
+ dodir /usr/share/${PN}
+ cp -a test "${ED}//usr/share/${PN}/" || die
+}