summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-12-03 17:07:25 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-12-03 17:12:44 +0100
commita7bf0286040a1f66b513bc028bf5d966115215f6 (patch)
tree39f18285994ed2f90bac35d574c2512954a0fdd9 /dev-ros/tf2_ros/tf2_ros-0.6.5.ebuild
parentdev-ros/tf2_py: Bump to 0.6.5. (diff)
downloadgentoo-a7bf0286040a1f66b513bc028bf5d966115215f6.tar.gz
gentoo-a7bf0286040a1f66b513bc028bf5d966115215f6.tar.bz2
gentoo-a7bf0286040a1f66b513bc028bf5d966115215f6.zip
dev-ros/tf2_ros: Bump to 0.6.5.
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/tf2_ros/tf2_ros-0.6.5.ebuild')
-rw-r--r--dev-ros/tf2_ros/tf2_ros-0.6.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/tf2_ros/tf2_ros-0.6.5.ebuild b/dev-ros/tf2_ros/tf2_ros-0.6.5.ebuild
new file mode 100644
index 000000000000..fe678113d01c
--- /dev/null
+++ b/dev-ros/tf2_ros/tf2_ros-0.6.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="ROS bindings for the tf2 library, for both Python and C++"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/message_filters
+ dev-ros/roscpp
+ dev-ros/rosgraph
+ dev-libs/boost:=[threads]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_py[${PYTHON_USEDEP}]
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"