summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-09 12:06:39 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-09 12:46:00 +0200
commit4d23cb8a59f826e72b6d0eb1135e727368fd2282 (patch)
treeede676363386beafbf6f0da846228bb1b6225390 /dev-ros/tf2_ros/tf2_ros-0.7.2.ebuild
parentdev-ros/tf2_sensor_msgs: Remove old (diff)
downloadgentoo-4d23cb8a59f826e72b6d0eb1135e727368fd2282.tar.gz
gentoo-4d23cb8a59f826e72b6d0eb1135e727368fd2282.tar.bz2
gentoo-4d23cb8a59f826e72b6d0eb1135e727368fd2282.zip
dev-ros/tf2_ros: bump eapi
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/tf2_ros/tf2_ros-0.7.2.ebuild')
-rw-r--r--dev-ros/tf2_ros/tf2_ros-0.7.2.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-ros/tf2_ros/tf2_ros-0.7.2.ebuild b/dev-ros/tf2_ros/tf2_ros-0.7.2.ebuild
index a4620c6710f0..0cecd8403f76 100644
--- a/dev-ros/tf2_ros/tf2_ros-0.7.2.ebuild
+++ b/dev-ros/tf2_ros/tf2_ros-0.7.2.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/geometry2"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
@@ -24,8 +23,11 @@ RDEPEND="
dev-ros/tf2
dev-ros/tf2_py[${PYTHON_USEDEP}]
dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
- test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"