summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 14:20:34 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 14:20:34 +0200
commitced5dc9d8187906c45905dda3cd43681d6f29799 (patch)
treeb03d22c7dfbe7947907473022d7d43145b0a1fe3 /dev-ros/timestamp_tools
parentdev-ros/driver_base: Initial import. Ebuild by me. (diff)
downloadgentoo-ced5dc9d8187906c45905dda3cd43681d6f29799.tar.gz
gentoo-ced5dc9d8187906c45905dda3cd43681d6f29799.tar.bz2
gentoo-ced5dc9d8187906c45905dda3cd43681d6f29799.zip
dev-ros/timestamp_tools: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/timestamp_tools')
-rw-r--r--dev-ros/timestamp_tools/Manifest1
-rw-r--r--dev-ros/timestamp_tools/files/tests.patch14
-rw-r--r--dev-ros/timestamp_tools/metadata.xml5
-rw-r--r--dev-ros/timestamp_tools/timestamp_tools-1.6.8.ebuild23
-rw-r--r--dev-ros/timestamp_tools/timestamp_tools-9999.ebuild23
5 files changed, 66 insertions, 0 deletions
diff --git a/dev-ros/timestamp_tools/Manifest b/dev-ros/timestamp_tools/Manifest
new file mode 100644
index 000000000000..b6adff09cb2f
--- /dev/null
+++ b/dev-ros/timestamp_tools/Manifest
@@ -0,0 +1 @@
+DIST driver_common-1.6.8.tar.gz 15055 SHA256 74b0464902b3853ff24a2a126767c8fbec2e901b9cd86756e00efaa902e14eaa SHA512 b698143d08785088ac13e62f5b96676bd590a84e4ffb147fa3698be6a8ded510f648d043ecdc1d31ba7b95fb3041d06ee1a39b224c359b8612adebdba259d188 WHIRLPOOL 918b11d2b5d8f90990b7545b992e27b1ae00777c6cc917414b817e9b8909b38e54f808d9bd9477fbf24fddbca08c61543e95d2b5eeb676a776e2fa7682de9958
diff --git a/dev-ros/timestamp_tools/files/tests.patch b/dev-ros/timestamp_tools/files/tests.patch
new file mode 100644
index 000000000000..c73d09a1b1ac
--- /dev/null
+++ b/dev-ros/timestamp_tools/files/tests.patch
@@ -0,0 +1,14 @@
+Index: driver_common-1.6.8/timestamp_tools/CMakeLists.txt
+===================================================================
+--- driver_common-1.6.8.orig/timestamp_tools/CMakeLists.txt
++++ driver_common-1.6.8/timestamp_tools/CMakeLists.txt
+@@ -17,5 +17,7 @@ install(DIRECTORY include/${PROJECT_NAME
+ DESTINATION ${CATKIN_PACKAGE_INCLUDE_DESTINATION}
+ FILES_MATCHING PATTERN "*.h")
+
++if(CATKIN_ENABLE_TESTING)
+ catkin_add_gtest(test_trigger_matcher test/test_trigger_matcher.cpp)
+-target_link_libraries(test_trigger_matcher ${catkin_LIBRARIES})
+\ No newline at end of file
++target_link_libraries(test_trigger_matcher ${catkin_LIBRARIES})
++endif()
diff --git a/dev-ros/timestamp_tools/metadata.xml b/dev-ros/timestamp_tools/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/timestamp_tools/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/timestamp_tools/timestamp_tools-1.6.8.ebuild b/dev-ros/timestamp_tools/timestamp_tools-1.6.8.ebuild
new file mode 100644
index 000000000000..ff904893e2df
--- /dev/null
+++ b/dev-ros/timestamp_tools/timestamp_tools-1.6.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/driver_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Classes to help timestamp hardware events"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roslib
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/tests.patch" )
diff --git a/dev-ros/timestamp_tools/timestamp_tools-9999.ebuild b/dev-ros/timestamp_tools/timestamp_tools-9999.ebuild
new file mode 100644
index 000000000000..ff904893e2df
--- /dev/null
+++ b/dev-ros/timestamp_tools/timestamp_tools-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/driver_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Classes to help timestamp hardware events"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roslib
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/tests.patch" )