summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-17 08:57:15 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-17 08:57:15 +0200
commit03e59a360509bf8bd85ceb437f35493d1f272f39 (patch)
tree8024928c4abfe4b3721b1bc4727a90bcfe382d70 /dev-ros
parentdev-ros/tf2_py: Bump to 0.6.3. (diff)
downloadgentoo-03e59a360509bf8bd85ceb437f35493d1f272f39.tar.gz
gentoo-03e59a360509bf8bd85ceb437f35493d1f272f39.tar.bz2
gentoo-03e59a360509bf8bd85ceb437f35493d1f272f39.zip
dev-ros/tf2_ros: Bump to 0.6.3.
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/tf2_ros/Manifest1
-rw-r--r--dev-ros/tf2_ros/tf2_ros-0.6.3.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/tf2_ros/Manifest b/dev-ros/tf2_ros/Manifest
index d6b94350f53f..50cdc2fccc9d 100644
--- a/dev-ros/tf2_ros/Manifest
+++ b/dev-ros/tf2_ros/Manifest
@@ -1,2 +1,3 @@
DIST geometry2-0.6.1.tar.gz 162912 BLAKE2B 103937894921111da2058f61b555cb9498ea053e8c8dac357383fc326e214bf88e74a65c97021cf7dd0ecb2b5a38606c3ad3660e365af145349c764660c56726 SHA512 392719295eedf4a5f580390f076a14f9909f49681223d8c50ccb88d57b784c1e50383d28ff10bddc21424662f261504c29525c24965a51462d6e9e62d702d6ef
DIST geometry2-0.6.2.tar.gz 166807 BLAKE2B 821ad4bc68ff2703df53d3d85505cd892f0399abe99b7fbff13852bda0895e8b28bc4e6aaff0590d4bc7124d36c396e7c477be0a9d56c532fe491099ccb3990d SHA512 fddf5e114600a2814bfecc71c52ddc820fa113fbd07584cd43d4b8a5eb395e9d9b1f78e28c193866920690edb8a5b220bfed949a6e6741926dcea1fc654edadf
+DIST geometry2-0.6.3.tar.gz 167590 BLAKE2B 96ef84a40a8d75bbd3303774163b41d29086085cc175010731584ebfb71da87fa5264caf24c8b5b6b4450b9befc2625c6b118b8a60d032c78ce315554af74370 SHA512 f46ae3c9240073252d910e1e4b1f412ed4f534b2b3166852330ae82f1d37dde16527e12ef8a4140b41587ec664f83d8c2271376b606c55c51cee681c4d10b75b
diff --git a/dev-ros/tf2_ros/tf2_ros-0.6.3.ebuild b/dev-ros/tf2_ros/tf2_ros-0.6.3.ebuild
new file mode 100644
index 000000000000..0e85b91f5107
--- /dev/null
+++ b/dev-ros/tf2_ros/tf2_ros-0.6.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="ROS bindings for the tf2 library, for both Python and C++"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/message_filters
+ dev-ros/roscpp
+ dev-ros/rosgraph
+ dev-libs/boost:=[threads]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_py[${PYTHON_USEDEP}]
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"