summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-05-18 19:09:05 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-05-18 19:30:57 +0200
commit5998ef9f2cb6c18143d50cee2149f1b85a5d81b7 (patch)
treebc2d6a98114ed5925efdf810f91bca7055beab3b /dev-ros
parentnet-vpn/tailscale: convert 0.98 to source ebuild (diff)
downloadgentoo-5998ef9f2cb6c18143d50cee2149f1b85a5d81b7.tar.gz
gentoo-5998ef9f2cb6c18143d50cee2149f1b85a5d81b7.tar.bz2
gentoo-5998ef9f2cb6c18143d50cee2149f1b85a5d81b7.zip
dev-ros/unique_id: eapi7
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/unique_id/unique_id-1.0.6.ebuild8
-rw-r--r--dev-ros/unique_id/unique_id-9999.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/dev-ros/unique_id/unique_id-1.0.6.ebuild b/dev-ros/unique_id/unique_id-1.0.6.ebuild
index 612f302dfc98..7ff69d0fac63 100644
--- a/dev-ros/unique_id/unique_id-1.0.6.ebuild
+++ b/dev-ros/unique_id/unique_id-1.0.6.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-geographic-info/unique_identifier"
VER_PREFIX=unique_identifier-
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
ROS_SUBDIR=${PN}
inherit ros-catkin
@@ -16,9 +15,10 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-ros/uuid_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/rospy[${PYTHON_USEDEP}]
dev-ros/roscpp
"
DEPEND="${RDEPEND}
+ dev-ros/uuid_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
test? ( dev-cpp/gtest dev-python/nose[${PYTHON_USEDEP}] )"
diff --git a/dev-ros/unique_id/unique_id-9999.ebuild b/dev-ros/unique_id/unique_id-9999.ebuild
index c67faa3ad095..7ff69d0fac63 100644
--- a/dev-ros/unique_id/unique_id-9999.ebuild
+++ b/dev-ros/unique_id/unique_id-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-geographic-info/unique_identifier"
VER_PREFIX=unique_identifier-
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
ROS_SUBDIR=${PN}
inherit ros-catkin
@@ -16,9 +15,10 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-ros/uuid_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/rospy[${PYTHON_USEDEP}]
dev-ros/roscpp
"
DEPEND="${RDEPEND}
+ dev-ros/uuid_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
test? ( dev-cpp/gtest dev-python/nose[${PYTHON_USEDEP}] )"