summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-30 12:36:34 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-30 14:03:50 +0200
commit61b812216841a9ac06ce96e4a4deaf0aceff34a5 (patch)
treeebcf19ea0d2d625fd68e8d6d72f385a5f3754cb2 /dev-ros
parentdev-ros/robot_pose_ekf: Initial import. Ebuild by me. (diff)
downloadgentoo-61b812216841a9ac06ce96e4a4deaf0aceff34a5.tar.gz
gentoo-61b812216841a9ac06ce96e4a4deaf0aceff34a5.tar.bz2
gentoo-61b812216841a9ac06ce96e4a4deaf0aceff34a5.zip
dev-ros/nav_core: Initial import. Ebuild by me.
Package-Manager: portage-2.2.22
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/nav_core/Manifest1
-rw-r--r--dev-ros/nav_core/metadata.xml5
-rw-r--r--dev-ros/nav_core/nav_core-1.13.0.ebuild23
-rw-r--r--dev-ros/nav_core/nav_core-9999.ebuild23
4 files changed, 52 insertions, 0 deletions
diff --git a/dev-ros/nav_core/Manifest b/dev-ros/nav_core/Manifest
new file mode 100644
index 000000000000..2ab0c74f2366
--- /dev/null
+++ b/dev-ros/nav_core/Manifest
@@ -0,0 +1 @@
+DIST navigation-1.13.0.tar.gz 336419 SHA256 5ef288325a0de4accfb4ef0cc37d9e9c4106a05d98b0ae5757f6c4823abada97 SHA512 1b686d4d1e930901dcf899fb73c8609855c3bb6d797322f6f3b9ea7ccb349f98802870b44e0fcbee4e68abebeecbaff57d453dc790fbc908cd23b8afda22e1af WHIRLPOOL 096103d8b774205995a12d294c820187fb89302285b363f6e6b9a4bb1e30a2edf9b33a451effc00b8aeec4d8f40664f61266314d389b9c668c0d7cf2152f70dd
diff --git a/dev-ros/nav_core/metadata.xml b/dev-ros/nav_core/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/nav_core/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/nav_core/nav_core-1.13.0.ebuild b/dev-ros/nav_core/nav_core-1.13.0.ebuild
new file mode 100644
index 000000000000..c73919561b31
--- /dev/null
+++ b/dev-ros/nav_core/nav_core-1.13.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Common interfaces for navigation specific robot actions"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-ros/costmap_2d
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/nav_core/nav_core-9999.ebuild b/dev-ros/nav_core/nav_core-9999.ebuild
new file mode 100644
index 000000000000..c73919561b31
--- /dev/null
+++ b/dev-ros/nav_core/nav_core-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Common interfaces for navigation specific robot actions"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-ros/costmap_2d
+"
+DEPEND="${RDEPEND}"