summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-08-04 20:36:14 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-08-04 20:46:32 +0200
commit65fc7553f00397cd8345e2f1c5cf681c16dd6f03 (patch)
tree886af70702d5690a06260663918df33b871ba1e7 /dev-ros
parentdev-ros/amcl: Bump to 1.16.2. (diff)
downloadgentoo-65fc7553f00397cd8345e2f1c5cf681c16dd6f03.tar.gz
gentoo-65fc7553f00397cd8345e2f1c5cf681c16dd6f03.tar.bz2
gentoo-65fc7553f00397cd8345e2f1c5cf681c16dd6f03.zip
dev-ros/base_local_planner: Bump to 1.16.2.
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/base_local_planner/Manifest1
-rw-r--r--dev-ros/base_local_planner/base_local_planner-1.16.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ros/base_local_planner/Manifest b/dev-ros/base_local_planner/Manifest
index 2e0595a1965d..67d0b9c053da 100644
--- a/dev-ros/base_local_planner/Manifest
+++ b/dev-ros/base_local_planner/Manifest
@@ -1 +1,2 @@
DIST navigation-1.16.1.tar.gz 336908 BLAKE2B 0f22db60352a0f50938ae18104ecad72c2e06eedeb2da8f6afe09bdc346868fcd71c90b0243c366b9fd0e7a26fef7551ab6a4febe87ab8d66af5ce3497c68770 SHA512 f6742f5afcaff2d1fc699e2695845b148bb16523e301f79577a8073fcc829541158b7c463f2e5bd9f69571f8b4042dbfacfe563de54b16193b5a31721c5f6faf
+DIST navigation-1.16.2.tar.gz 337389 BLAKE2B a21d014df02ebf8046245777bb42fe3bccaf65af4c607532c4fb72e0b2c43870d1ff1c32c882a0418363708c0fa0c74925943beca2110a5f19b77a65e0a871fc SHA512 890eb391a8a70b3b17aa870dfa79bf48199cf3dcf7a8703b0e005b22ffd404edf723d73e30a04f902f436899fe321894bf3da7610f374b1a95b247629f64256e
diff --git a/dev-ros/base_local_planner/base_local_planner-1.16.2.ebuild b/dev-ros/base_local_planner/base_local_planner-1.16.2.ebuild
new file mode 100644
index 000000000000..b9d3cfb7e498
--- /dev/null
+++ b/dev-ros/base_local_planner/base_local_planner-1.16.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Trajectory Rollout and Dynamic Window approaches to local robot navigation on a plane"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/angles
+ >=dev-ros/costmap_2d-1.16
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-cpp/eigen:3
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ >=dev-ros/nav_core-1.16
+ dev-ros/pluginlib
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_ros
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/voxel_grid
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+ test? ( dev-cpp/gtest dev-ros/rosunit[${PYTHON_USEDEP}] )
+"