summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-12-20 17:10:59 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-12-20 17:53:57 +0100
commit6ebaeb44921a66ac5a2d5796856a292af15ec384 (patch)
tree50f9f3decbd551d871ffcb65de0a967192c53e09 /dev-ros
parentdev-ros/depth_image_proc: Bump to 1.12.22. (diff)
downloadgentoo-6ebaeb44921a66ac5a2d5796856a292af15ec384.tar.gz
gentoo-6ebaeb44921a66ac5a2d5796856a292af15ec384.tar.bz2
gentoo-6ebaeb44921a66ac5a2d5796856a292af15ec384.zip
dev-ros/image_proc: Bump to 1.12.22.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/image_proc/Manifest1
-rw-r--r--dev-ros/image_proc/image_proc-1.12.22.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/image_proc/Manifest b/dev-ros/image_proc/Manifest
index b26484c5f5a6..c825d78f9f40 100644
--- a/dev-ros/image_proc/Manifest
+++ b/dev-ros/image_proc/Manifest
@@ -1,3 +1,4 @@
DIST image_pipeline-1.12.19.tar.gz 130635 BLAKE2B 23709220248c86900c092a94a688cb428ceb58aba621e078cece903038345339e75706b0496aacd616e8a5e67522fff781d6a48022f8e6c231bb76eed9417b6e SHA512 f0677e4a811622ffc19792af828f4766408b6a051d271950a8a096d064b043dae1457b2a6f2d59fe5c2971795db04e7abf5e0878ead1428a4da19033693829ba
DIST image_pipeline-1.12.20.tar.gz 137888 BLAKE2B 2fa362acf59e545c794136262bab98bd5bf5c9025306df5b3f46fd4f498a13c99ef902653f8725564e02f6d1178ba7b77f973d248e4229c80251ad8f5747fb56 SHA512 37a45cfcc8bdb8b40477860e29f72671d423d4531156f5901128c32a6c41d27f235cdac216502d614ab7ddab5e66c2f343baaa0fd22cf83cb38e667fbbc111c5
DIST image_pipeline-1.12.21.tar.gz 139264 BLAKE2B 0b60057d35a250b0f4938ad79d893b922501d9416a6a7122c49023f632affd06c1c82bfddff0f10bbebe683d8dd50eb4d947d5086a8bb6935da98f8a2d146eed SHA512 76f06e7a1effb3098454496e01a8c14b34a37a3ea96ac51a0deb860b6891b37d354dcf7d9c06389476decaa90c3097c4495e34d04f70ad6a571fc5469eda2f6c
+DIST image_pipeline-1.12.22.tar.gz 139237 BLAKE2B 9c4ad324494f7e9db935cceed562840bb7ed7af730655398c9ac410722faf7d6747010ef0bbee55f14b555b6b2a6756de3edde31d84c3ae3fad123cea4a85bfe SHA512 34c17bd13625dc0a3c94639ce5ea17cc7674b0035b425c10020178d08037fb4fd081a84d7e83c75822f58c0ba2faead351702dbbc75c821d2f8c17bda351c560
diff --git a/dev-ros/image_proc/image_proc-1.12.22.ebuild b/dev-ros/image_proc/image_proc-1.12.22.ebuild
new file mode 100644
index 000000000000..c70f308ec815
--- /dev/null
+++ b/dev-ros/image_proc/image_proc-1.12.22.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Single image rectification and color processing"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure
+ dev-ros/image_geometry
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ media-libs/opencv:=
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}"