summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-11-02 10:23:03 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-11-02 10:23:16 +0100
commit7b9b8646a826262d8f092c4b0cca4c6e4de81603 (patch)
tree71d43b70f07ae12fc73aab50453c04fe8a8be455 /dev-ros
parentsci-libs/rtabmap: Bump to 0.10.10 (diff)
downloadgentoo-7b9b8646a826262d8f092c4b0cca4c6e4de81603.tar.gz
gentoo-7b9b8646a826262d8f092c4b0cca4c6e4de81603.tar.bz2
gentoo-7b9b8646a826262d8f092c4b0cca4c6e4de81603.zip
dev-ros/robot_pose_publisher: Initial import. Ebuild by me.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/robot_pose_publisher/Manifest1
-rw-r--r--dev-ros/robot_pose_publisher/metadata.xml5
-rw-r--r--dev-ros/robot_pose_publisher/robot_pose_publisher-0.2.3.ebuild21
-rw-r--r--dev-ros/robot_pose_publisher/robot_pose_publisher-9999.ebuild21
4 files changed, 48 insertions, 0 deletions
diff --git a/dev-ros/robot_pose_publisher/Manifest b/dev-ros/robot_pose_publisher/Manifest
new file mode 100644
index 000000000000..872de2f98e03
--- /dev/null
+++ b/dev-ros/robot_pose_publisher/Manifest
@@ -0,0 +1 @@
+DIST robot_pose_publisher-0.2.3.tar.gz 4225 SHA256 b8e1f7e8957a89a929e66a3222261431e227639100f21a184e22dbd4226a467f SHA512 393c906754015161643a3047e8ab6690292d4446fc89fb1caa6e1a8fd25e6d880bcd23ea9780eea7c2fe7eb83331455894c93a90fdce01d0f483cae90b653314 WHIRLPOOL 4395b4a4395725eb1ff74768f92f0b39c42163b1c5a237d6776c01ec747e80e4fef3ce51ce632877f586e8219e6a9ea97ebfe3c591d1a807d4989239aa3675a6
diff --git a/dev-ros/robot_pose_publisher/metadata.xml b/dev-ros/robot_pose_publisher/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/robot_pose_publisher/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/robot_pose_publisher/robot_pose_publisher-0.2.3.ebuild b/dev-ros/robot_pose_publisher/robot_pose_publisher-0.2.3.ebuild
new file mode 100644
index 000000000000..ae81a9889c3c
--- /dev/null
+++ b/dev-ros/robot_pose_publisher/robot_pose_publisher-0.2.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/WPI-RAIL/robot_pose_publisher"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="A Simple Node to Publish the Robot's Position Relative to the Map using TFs"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/robot_pose_publisher/robot_pose_publisher-9999.ebuild b/dev-ros/robot_pose_publisher/robot_pose_publisher-9999.ebuild
new file mode 100644
index 000000000000..ae81a9889c3c
--- /dev/null
+++ b/dev-ros/robot_pose_publisher/robot_pose_publisher-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/WPI-RAIL/robot_pose_publisher"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="A Simple Node to Publish the Robot's Position Relative to the Map using TFs"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"