summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-05-12 13:10:34 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-05-12 13:13:34 +0200
commita7a539f12bf4c3d6e1c6c286d56a02c6cd3bacd4 (patch)
treeab51d09a86f3129fa6e244203f5db1ae0a00a595 /dev-ros
parentdev-ros/tf2_ros: Bump to 0.6.2. (diff)
downloadgentoo-a7a539f12bf4c3d6e1c6c286d56a02c6cd3bacd4.tar.gz
gentoo-a7a539f12bf4c3d6e1c6c286d56a02c6cd3bacd4.tar.bz2
gentoo-a7a539f12bf4c3d6e1c6c286d56a02c6cd3bacd4.zip
dev-ros/tf2_sensor_msgs: Bump to 0.6.2.
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/tf2_sensor_msgs/Manifest1
-rw-r--r--dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.6.2.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/tf2_sensor_msgs/Manifest b/dev-ros/tf2_sensor_msgs/Manifest
index 91aa82a21728..d6b94350f53f 100644
--- a/dev-ros/tf2_sensor_msgs/Manifest
+++ b/dev-ros/tf2_sensor_msgs/Manifest
@@ -1 +1,2 @@
DIST geometry2-0.6.1.tar.gz 162912 BLAKE2B 103937894921111da2058f61b555cb9498ea053e8c8dac357383fc326e214bf88e74a65c97021cf7dd0ecb2b5a38606c3ad3660e365af145349c764660c56726 SHA512 392719295eedf4a5f580390f076a14f9909f49681223d8c50ccb88d57b784c1e50383d28ff10bddc21424662f261504c29525c24965a51462d6e9e62d702d6ef
+DIST geometry2-0.6.2.tar.gz 166807 BLAKE2B 821ad4bc68ff2703df53d3d85505cd892f0399abe99b7fbff13852bda0895e8b28bc4e6aaff0590d4bc7124d36c396e7c477be0a9d56c532fe491099ccb3990d SHA512 fddf5e114600a2814bfecc71c52ddc820fa113fbd07584cd43d4b8a5eb395e9d9b1f78e28c193866920690edb8a5b220bfed949a6e6741926dcea1fc654edadf
diff --git a/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.6.2.ebuild b/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.6.2.ebuild
new file mode 100644
index 000000000000..b4c841429ce6
--- /dev/null
+++ b/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.6.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Transform sensor_msgs with tf. Most notably, PointCloud2"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2_ros[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )
+ dev-ros/cmake_modules"