summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-07-18 11:41:28 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-07-18 14:13:24 +0200
commitac1470787044d4dd51e28032aa49ab6b1a053819 (patch)
tree398c1ed6e43e2327db6c3600a8b323e6299ae3ee /dev-ros
parentdev-ros/rosserial_msgs: Bump to 0.7.2. (diff)
downloadgentoo-ac1470787044d4dd51e28032aa49ab6b1a053819.tar.gz
gentoo-ac1470787044d4dd51e28032aa49ab6b1a053819.tar.bz2
gentoo-ac1470787044d4dd51e28032aa49ab6b1a053819.zip
dev-ros/rosserial_python: Bump to 0.7.2.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/rosserial_python/Manifest1
-rw-r--r--dev-ros/rosserial_python/rosserial_python-0.7.2.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rosserial_python/Manifest b/dev-ros/rosserial_python/Manifest
index 2af16836775c..7a1134bfa85d 100644
--- a/dev-ros/rosserial_python/Manifest
+++ b/dev-ros/rosserial_python/Manifest
@@ -1 +1,2 @@
DIST rosserial-0.7.1.tar.gz 102204 SHA256 203aeb4b1440da89f8e571372766f099d5d950901f0fa6991cc3b780aeca3331 SHA512 f63cdc674e2510e8d2990894fe21fcce7760cef18a7ce42951a07898d089a185c137d6643ff062a5bb4dfd2da0bd1571c077811ea67e8aee84bc2ad66d3160c5 WHIRLPOOL 8fddee9f232fff9d463855649c16fb01b3c85e8576481b7ca90fd22b00d95ca243b28d59df82d51643354f8219a8c7cad429aaa4b8822fe07cf3be54cdf0dfc7
+DIST rosserial-0.7.2.tar.gz 143811 SHA256 44abc49d02d9b0bddb7d07c73c1f0e8f633430e86f9b484a0bc9fce757b8797d SHA512 d6f7250050f68884e943aa4cc59740506fa317ab60973deb25da824d8614a3fb7c16ed5ce2123e0eb181ab906d8f7156c3ba1ea480468a01df45ab682cddc2cd WHIRLPOOL 9d1dcd9244bc11f8a4a4c57cf3bbd2eda0d4045687cac7593c4b5132c7bde6e8bbe28d23d4e473af283754a1413920e4f03de3dc673d98a61992442042a7e7c8
diff --git a/dev-ros/rosserial_python/rosserial_python-0.7.2.ebuild b/dev-ros/rosserial_python/rosserial_python-0.7.2.ebuild
new file mode 100644
index 000000000000..ae37a0f34643
--- /dev/null
+++ b/dev-ros/rosserial_python/rosserial_python-0.7.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/rosserial"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="A Python-based implementation of the ROS serial protocol"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosserial_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"