summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-08-07 17:43:07 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-08-07 17:48:57 +0200
commitb97b6ae03fc5623ee75d66f22e5e1ea9aa53778c (patch)
tree3978009cb05d268d0d55325773f15dedd6b541b0 /dev-ros
parentros-meta/qt_gui_core: Bump to 0.3.10. (diff)
downloadgentoo-b97b6ae03fc5623ee75d66f22e5e1ea9aa53778c.tar.gz
gentoo-b97b6ae03fc5623ee75d66f22e5e1ea9aa53778c.tar.bz2
gentoo-b97b6ae03fc5623ee75d66f22e5e1ea9aa53778c.zip
dev-ros/python_qt_binding: bump to 0.3.4
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/python_qt_binding/Manifest1
-rw-r--r--dev-ros/python_qt_binding/python_qt_binding-0.3.4.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/python_qt_binding/Manifest b/dev-ros/python_qt_binding/Manifest
index c15ae440bc7e..7ce6a8d13667 100644
--- a/dev-ros/python_qt_binding/Manifest
+++ b/dev-ros/python_qt_binding/Manifest
@@ -1,2 +1,3 @@
DIST python_qt_binding-0.3.2.tar.gz 12047 BLAKE2B 330ab27cface576d37cfca709a9758b6499a181b8e2734c04ef0f55b84a3d45a4ae821fbf572337e71115b4db57839f900e406b9ce8b3cfc71daa2d4ff4b143c SHA512 777d7ba00652d34994648615125f6c426170a1723570de35b9e5a060d0f077b563a57c9b0cbe7bd85a7ed2f5f011797e9102918a27df4f0096831cce0bb80304
DIST python_qt_binding-0.3.3.tar.gz 12114 BLAKE2B 12a2e785746ec3d9fe7b387a9e727bfacb5e37da90702c728c8e874c52cd3e4cfc000936d8f17cefbeeb98673de8c21f066eded743df3b5325b88e785f3dc100 SHA512 0dfd698b390a87e0619e93a291656c329ff37713411c5a805e720aeedf9fefd43fc780bbdba351cd1a73e30d67ce8e93a98b5ba6b5584a807d829611ac232263
+DIST python_qt_binding-0.3.4.tar.gz 12255 BLAKE2B bc72aa806098d460e5b884bde7664f295399555d96e10b66791e59a26d1e61dd22aabecf9b40b5d14f61c2c906c18ff3fe2cd03de6108d7d9c2c649d553ab09d SHA512 df5fc2c6a744e66d0c03089e15ce4cfb3890d8fd67d826a3832d22cf99de235e18720c59f737c3ddacefb02dac5571d64042dd862c10ea4c44835063037eb533
diff --git a/dev-ros/python_qt_binding/python_qt_binding-0.3.4.ebuild b/dev-ros/python_qt_binding/python_qt_binding-0.3.4.ebuild
new file mode 100644
index 000000000000..c7463631a14c
--- /dev/null
+++ b/dev-ros/python_qt_binding/python_qt_binding-0.3.4.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/python_qt_binding"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Infrastructure for an integrated graphical user interface based on Qt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"