summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-13 14:34:06 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-13 14:53:20 +0100
commitccad656f858a4c0149b03a9afa9b2c449083ead3 (patch)
tree4cce28d722eb6f2836596f68228fb33d655561e1 /dev-ros
parentdev-ros/ament_cmake_export_libraries: use python-any-r1 (diff)
downloadgentoo-ccad656f858a4c0149b03a9afa9b2c449083ead3.tar.gz
gentoo-ccad656f858a4c0149b03a9afa9b2c449083ead3.tar.bz2
gentoo-ccad656f858a4c0149b03a9afa9b2c449083ead3.zip
dev-ros/ament_cmake_export_interfaces: use python-any-r1
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/ament_cmake_export_interfaces/ament_cmake_export_interfaces-0.8.1.ebuild25
-rw-r--r--dev-ros/ament_cmake_export_interfaces/ament_cmake_export_interfaces-9999.ebuild25
2 files changed, 18 insertions, 32 deletions
diff --git a/dev-ros/ament_cmake_export_interfaces/ament_cmake_export_interfaces-0.8.1.ebuild b/dev-ros/ament_cmake_export_interfaces/ament_cmake_export_interfaces-0.8.1.ebuild
index df1716f5003d..ecee8305483e 100644
--- a/dev-ros/ament_cmake_export_interfaces/ament_cmake_export_interfaces-0.8.1.ebuild
+++ b/dev-ros/ament_cmake_export_interfaces/ament_cmake_export_interfaces-0.8.1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python{3_6,3_7} )
-inherit cmake-utils python-r1
+inherit cmake-utils python-any-r1
ROS_PN="ament_cmake"
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -30,20 +30,13 @@ else
fi
IUSE=""
-DEPEND="
- dev-ros/ament_cmake_core[${PYTHON_USEDEP}]
- dev-ros/ament_cmake_export_libraries[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-ros/ament_cmake_core
+ dev-ros/ament_cmake_export_libraries
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"
-RDEPEND="${DEPEND}"
-BDEPEND="${DEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_configure() {
- # This is a build tool that does not install python-related files
- # ... but we need to propagate the deps and use python3 to build it.
- local pyimpl="${PYTHON_COMPAT[0]}"
- python_export "${pyimpl}" EPYTHON PYTHON
- python_wrapper_setup
- cmake-utils_src_configure
-}
diff --git a/dev-ros/ament_cmake_export_interfaces/ament_cmake_export_interfaces-9999.ebuild b/dev-ros/ament_cmake_export_interfaces/ament_cmake_export_interfaces-9999.ebuild
index df1716f5003d..ecee8305483e 100644
--- a/dev-ros/ament_cmake_export_interfaces/ament_cmake_export_interfaces-9999.ebuild
+++ b/dev-ros/ament_cmake_export_interfaces/ament_cmake_export_interfaces-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python{3_6,3_7} )
-inherit cmake-utils python-r1
+inherit cmake-utils python-any-r1
ROS_PN="ament_cmake"
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -30,20 +30,13 @@ else
fi
IUSE=""
-DEPEND="
- dev-ros/ament_cmake_core[${PYTHON_USEDEP}]
- dev-ros/ament_cmake_export_libraries[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-ros/ament_cmake_core
+ dev-ros/ament_cmake_export_libraries
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"
-RDEPEND="${DEPEND}"
-BDEPEND="${DEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_configure() {
- # This is a build tool that does not install python-related files
- # ... but we need to propagate the deps and use python3 to build it.
- local pyimpl="${PYTHON_COMPAT[0]}"
- python_export "${pyimpl}" EPYTHON PYTHON
- python_wrapper_setup
- cmake-utils_src_configure
-}