summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-28 08:36:37 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-28 12:26:43 +0100
commitd94735210af54bb0146c346dd3ff6d5050dbe475 (patch)
tree40d7d4cb8650a9251bb2f6fbabd880c6f72c927e /dev-ros
parentdev-ros/rqt_msg: Bump to 0.4.6. (diff)
downloadgentoo-d94735210af54bb0146c346dd3ff6d5050dbe475.tar.gz
gentoo-d94735210af54bb0146c346dd3ff6d5050dbe475.tar.bz2
gentoo-d94735210af54bb0146c346dd3ff6d5050dbe475.zip
dev-ros/rqt_plot: Bump to 0.4.6.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/rqt_plot/Manifest1
-rw-r--r--dev-ros/rqt_plot/rqt_plot-0.4.6.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ros/rqt_plot/Manifest b/dev-ros/rqt_plot/Manifest
index 81d017359737..2450a368e66f 100644
--- a/dev-ros/rqt_plot/Manifest
+++ b/dev-ros/rqt_plot/Manifest
@@ -1,3 +1,4 @@
DIST rqt_common_plugins-0.4.3.tar.gz 242040 SHA256 a11a7cf416e6493776575e3795291a2a4cd215ce5c8090e4cd7cb361055db9c2 SHA512 91957bd70fe157e479ad982de7335210244479e238b814233f29b15f44f52cd443d890c0f626dccff69b55b462d514b879bb9e1321f4f9d169e28a42acba9ca7 WHIRLPOOL af7073935d6d7013342975ff8809dd0060c35d8a1fa92b289183f6e870246b4a3ab2214bdda545ed9644900b89822bedbf842284d34ee5b6b5fe8741537d4c24
DIST rqt_common_plugins-0.4.4.tar.gz 245149 SHA256 926b7835d4feea276518e9331de9bc3d25f8484ceb89d893948e6f2bf432cc7e SHA512 faa1e435aed0e158c802ac3b7cdf04a0fbf4cb340f2ed598970990827d384c5153a52657a474bf95af022166e5f6fb9acc926d1943b0093fea16c86699922d81 WHIRLPOOL 34848b6364af474072ef937f77deb583705db62a0e4ade7cc3b060e22af1a419c9beae4951791d81f0750619836cbbb9097956f9ec25f5768113dba253553d91
DIST rqt_common_plugins-0.4.5.tar.gz 245843 SHA256 11edfe5c636957714ca7ac9a525f5cee6e7cf39048fbdf8a6484ca5cc3f6a926 SHA512 713cd232a12019026fae66cee1f2169b375ff8e359204b723057761953d5e15fc4aaffe99ded71cc237abe1d73d011454a8ba321c8a5401a0eceb9479e577325 WHIRLPOOL a2d1644651a79132087def58dbfdf39e333de26b5339767a72b4ac4af1baf7ce9af93908a57bf5fcc7f39c7e7d2464b12685727e2c48107723af43a9e759d8b0
+DIST rqt_common_plugins-0.4.6.tar.gz 246810 SHA256 7abc266e409a4b834c50bf2aa0bdf9b994aa7f78661ecf593328ce012a8b5e82 SHA512 70aa634e0b53ee08703bbdcb8f2bef720671c432b46e849721838b039b21fab9d4b86cd3209e62ce79a74a1f0654a3a1eb92b654129ecf5618144060397873af WHIRLPOOL 9f657b6f07b2499f8d861c7fc65af47f2ac6df659ea21603c53b526b16c7921bff9dbeb8097f0d3efee469c2ef6a2a5ff8a3e1c747f13f0ada940056160772a5
diff --git a/dev-ros/rqt_plot/rqt_plot-0.4.6.ebuild b/dev-ros/rqt_plot/rqt_plot-0.4.6.ebuild
new file mode 100644
index 000000000000..4e34ff96d923
--- /dev/null
+++ b/dev-ros/rqt_plot/rqt_plot-0.4.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin visualizing numeric values in a 2D plot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ || ( dev-python/matplotlib[${PYTHON_USEDEP}] dev-python/pyqwt:5[${PYTHON_USEDEP}] )
+ dev-python/pyqtgraph[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"