summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-08-24 09:42:25 +0200
committerHans de Graaff <graaff@gentoo.org>2019-08-24 09:42:25 +0200
commit891075fe30f249dbb17b372fa8f1d7086c892c6a (patch)
treea499bd5d2b1f9d8cd8bceab1e4ae520fe7cc44d8 /dev-ruby/actioncable/actioncable-6.0.0.ebuild
parentdev-ruby/activerecord: add 6.0.0 (diff)
downloadgentoo-891075fe30f249dbb17b372fa8f1d7086c892c6a.tar.gz
gentoo-891075fe30f249dbb17b372fa8f1d7086c892c6a.tar.bz2
gentoo-891075fe30f249dbb17b372fa8f1d7086c892c6a.zip
dev-ruby/actioncable: add 6.0.0
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/actioncable/actioncable-6.0.0.ebuild')
-rw-r--r--dev-ruby/actioncable/actioncable-6.0.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/actioncable/actioncable-6.0.0.ebuild b/dev-ruby/actioncable/actioncable-6.0.0.ebuild
new file mode 100644
index 000000000000..636672deef02
--- /dev/null
+++ b/dev-ruby/actioncable/actioncable-6.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_EXTRAINSTALL="app"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Integrated WebSockets for Rails"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+# Tests require many new dependencies, skipping for now
+RESTRICT="test"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}:*
+ dev-ruby/nio4r:2
+ >=dev-ruby/websocket-driver-0.6.1:*
+"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/railties-4.2.0
+ dev-ruby/test-unit:2
+ >=dev-ruby/mocha-0.14.0:0.14
+ )"