summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-01-20 07:39:23 +0100
committerHans de Graaff <graaff@gentoo.org>2017-01-20 07:39:52 +0100
commit19c7cf709b34e5de586524a00b38e45e39c0340c (patch)
tree7da33588338144be0c98913f2ef402a4e897bf88 /dev-ruby/asciimath
parentdev-ruby/haml: add ruby23 (diff)
downloadgentoo-19c7cf709b34e5de586524a00b38e45e39c0340c.tar.gz
gentoo-19c7cf709b34e5de586524a00b38e45e39c0340c.tar.bz2
gentoo-19c7cf709b34e5de586524a00b38e45e39c0340c.zip
dev-ruby/asciimath: add 1.0.4
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/asciimath')
-rw-r--r--dev-ruby/asciimath/Manifest1
-rw-r--r--dev-ruby/asciimath/asciimath-1.0.4.ebuild23
-rw-r--r--dev-ruby/asciimath/files/asciimath-1.0.4-backslashes.patch22
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/asciimath/Manifest b/dev-ruby/asciimath/Manifest
index 1621793a3be2..85d7937734da 100644
--- a/dev-ruby/asciimath/Manifest
+++ b/dev-ruby/asciimath/Manifest
@@ -1 +1,2 @@
DIST asciimath-1.0.2.gem 13824 SHA256 d3c4485b6f32a61732d007337f74f6242d02ff572873b44bdbc1110cac9cfc37 SHA512 109995b8c67dc159671a1498f4507d926bdb10bb6c3a84552137fc84aa3477a237aa6c739de3011981f6815cd70fd9a0dc4ce47e172ab24d02a55f80ada0af46 WHIRLPOOL b83b33b31d059e0615f7eb84cc27540f1daa342b53f21e0ba57b7743a8914a73acf1a4f01225c3f5670776a4bc558deb11a24d19659fe603a8a4873d4bd86bf2
+DIST asciimath-1.0.4.gem 14336 SHA256 ac6271729317dfb166991261f5ab0893ec89c88621eaa3ef4787d5026f9c00b5 SHA512 e99e6f869dda3e0236392039e6dccf5912b095e32ee7acbfb4684a5d723d05f4d3c9961554d5beab2a3d703b1ef50c45ed15c0dbda2179ab35d3b1b6b8759b49 WHIRLPOOL 58f495835d5176a6573063ad8c81452381a87116ae70dace72d29f25661c8ce9f595a7e79da5603f5928291a24090927ec7a12234f36e3c987ffb9a1d23397d9
diff --git a/dev-ruby/asciimath/asciimath-1.0.4.ebuild b/dev-ruby/asciimath/asciimath-1.0.4.ebuild
new file mode 100644
index 000000000000..e1b86d5ec062
--- /dev/null
+++ b/dev-ruby/asciimath/asciimath-1.0.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc README.adoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby AsciiMath parsing and conversion library"
+HOMEPAGE="https://github.com/pepijnve/asciimath"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+RUBY_PATCHES=( ${P}-backslashes.patch )
diff --git a/dev-ruby/asciimath/files/asciimath-1.0.4-backslashes.patch b/dev-ruby/asciimath/files/asciimath-1.0.4-backslashes.patch
new file mode 100644
index 000000000000..9bf08ce34046
--- /dev/null
+++ b/dev-ruby/asciimath/files/asciimath-1.0.4-backslashes.patch
@@ -0,0 +1,22 @@
+From 1c06fdc8086077f4785479f78b0823a4a72d7948 Mon Sep 17 00:00:00 2001
+From: Pepijn Van Eeckhoudt <pepijn@vaneeckhoudt.net>
+Date: Thu, 12 May 2016 18:02:45 +0200
+Subject: [PATCH] Remove spurious backslashes
+
+---
+ spec/parser_spec.rb | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/spec/parser_spec.rb b/spec/parser_spec.rb
+index def78e0..3fa5a75 100644
+--- a/spec/parser_spec.rb
++++ b/spec/parser_spec.rb
+@@ -45,7 +45,7 @@
+ '"Скорость"=("Расстояние")/("Время")' =>
+ '<math><mtext>Скорость</mtext><mo>=</mo><mfrac><mtext>Расстояние</mtext><mtext>Время</mtext></mfrac></math>',
+ 'bb (a + b) + cc c = fr (d^n)' =>
+- '<math><mstyle mathvariant=\"bold\"><mrow><mi>a</mi><mo>+</mo><mi>b</mi></mrow></mstyle><mo>+</mo><mstyle mathvariant=\"script\"><mi>c</mi></mstyle><mo>=</mo><mstyle mathvariant=\"fraktur\"><msup><mi>d</mi><mi>n</mi></msup></mstyle></math>'
++ '<math><mstyle mathvariant="bold"><mrow><mi>a</mi><mo>+</mo><mi>b</mi></mrow></mstyle><mo>+</mo><mstyle mathvariant="script"><mi>c</mi></mstyle><mo>=</mo><mstyle mathvariant="fraktur"><msup><mi>d</mi><mi>n</mi></msup></mstyle></math>'
+ }
+
+ version = RUBY_VERSION.split('.').map { |s| s.to_i }