summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-05-13 06:24:14 +0200
committerHans de Graaff <graaff@gentoo.org>2018-05-13 06:24:14 +0200
commit7842e9d39fb05655acea1f33416d2da16bfabe5d (patch)
treef5a4d882835018725c689166b03ddd61865e4c90 /dev-ruby/atomic
parentdev-ruby/arel-helpers: add 2.7.0 (diff)
downloadgentoo-7842e9d39fb05655acea1f33416d2da16bfabe5d.tar.gz
gentoo-7842e9d39fb05655acea1f33416d2da16bfabe5d.tar.bz2
gentoo-7842e9d39fb05655acea1f33416d2da16bfabe5d.zip
dev-ruby/atomic: add 1.0.101
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/atomic')
-rw-r--r--dev-ruby/atomic/Manifest1
-rw-r--r--dev-ruby/atomic/atomic-1.1.101.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/atomic/Manifest b/dev-ruby/atomic/Manifest
index b2488b863ba1..c64c5671ec83 100644
--- a/dev-ruby/atomic/Manifest
+++ b/dev-ruby/atomic/Manifest
@@ -1,2 +1,3 @@
DIST atomic-1.1.100.gem 17920 BLAKE2B 47c96c49a572a6d6705b952e419e1a07f3b06de4e0235a4d9d98e6ff546c96aa9af69c39864107c6bec1ba7b92ca2a9ceef2cb5d5938c1c82f40973376920d6e SHA512 64c374b69b7ea8b7fc6aa3e189cb6ae3d4a9a214d410a83fa0ef464a55624792055c5e3e61adda3eff039aba604a0c1b710ba5304d33f27ae9cc6e421e8e1892
+DIST atomic-1.1.101.gem 17920 BLAKE2B 50f4efc215293e931380b6307231279b3c5ca055aa8082fee8575963a68b3d54262449bf45fb1a514dab18f53a1dd9e0467a0f7ac67dea7a45fcce09155721dd SHA512 59c82fa5ec984b7ecd97964ea075ea327511fd4e71cc5ac72d3fb573b777c9fb289f462d022ea1e0256b38dc369c9f7fa7a61b7af877bd06ec94252237111e8d
DIST atomic-1.1.99.gem 17920 BLAKE2B 814406dc3e38a3ec882eb47e20e6153da9f68c4dd6ba3bc3d3869c0542754ba38678512872b25379b12d902ad6f740b1da974680867d492d2c4620091c5a32c9 SHA512 9c7762f6c32d11b2c5b45be68954ca12c753d2b4683167158a037ce791d72b13d940beef5bf6dd445c8b12e358c62d2a9f43a609fb3b7c7357fea4f66316063c
diff --git a/dev-ruby/atomic/atomic-1.1.101.ebuild b/dev-ruby/atomic/atomic-1.1.101.ebuild
new file mode 100644
index 000000000000..f4208b05803a
--- /dev/null
+++ b/dev-ruby/atomic/atomic-1.1.101.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="An atomic reference implementation for JRuby, Rubinius, and MRI"
+HOMEPAGE="https://github.com/headius/ruby-atomic"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid compilation dependencies since we compile directly.
+ sed -i -e '/:test => :compile/ s:^:#:' \
+ -e '/extensiontask/,/end/ s:^:#:' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/atomic_reference$(get_modname) lib/ || die
+}