summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-11-16 10:45:34 +0100
committerHans de Graaff <graaff@gentoo.org>2019-11-16 10:57:40 +0100
commit109c7c980871d4db101fd5907c60e5a5804a519e (patch)
tree4f3336bfb89afe98f8ea7157f3201fdb0398b92d /dev-ruby/bundler-audit/bundler-audit-0.6.0.ebuild
parentdev-ruby/capybara: amd64 stable (diff)
downloadgentoo-109c7c980871d4db101fd5907c60e5a5804a519e.tar.gz
gentoo-109c7c980871d4db101fd5907c60e5a5804a519e.tar.bz2
gentoo-109c7c980871d4db101fd5907c60e5a5804a519e.zip
dev-ruby/bundler-audit: cleanup
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/bundler-audit/bundler-audit-0.6.0.ebuild')
-rw-r--r--dev-ruby/bundler-audit/bundler-audit-0.6.0.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-ruby/bundler-audit/bundler-audit-0.6.0.ebuild b/dev-ruby/bundler-audit/bundler-audit-0.6.0.ebuild
deleted file mode 100644
index e94212927181..000000000000
--- a/dev-ruby/bundler-audit/bundler-audit-0.6.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRAINSTALL="data"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Provides patch-level verification for Bundled apps"
-HOMEPAGE="https://github.com/rubysec/bundler-audit"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-
-#tests are trying to download AND have some odd failures
-#rspec ./spec/database_spec.rb:113 # Bundler::Audit::Database#size should eq 323
-#rspec ./spec/database_spec.rb:117 # Bundler::Audit::Database#advisories should return a list of all advisories.
-RESTRICT=test
-
-ruby_add_rdepend "
- >=dev-ruby/thor-0.18:0
- >=dev-ruby/bundler-1.2:0
-"
-
-all_ruby_prepare() {
- sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
-
- # Avoid specs that require network access via 'bundle install'
- rm spec/{integration,scanner}_spec.rb || die
-
- # Avoid specs that only work when the source is a git repository
- sed -i -e '/describe "path"/,/^ end/ s:^:#:' \
- -e '/describe "update!"/,/^ end/ s:^:#:' \
- spec/database_spec.rb || die
-}