summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-05-05 10:53:21 +0200
committerHans de Graaff <graaff@gentoo.org>2018-05-05 10:53:53 +0200
commitc94009b21052097771a35b175ac5cda95bd83938 (patch)
tree70c89efcc8dba564c30e676f3a683d2c0212274b /dev-ruby/celluloid
parentdev-ruby/celluloid-essentials: add ruby24 (diff)
downloadgentoo-c94009b21052097771a35b175ac5cda95bd83938.tar.gz
gentoo-c94009b21052097771a35b175ac5cda95bd83938.tar.bz2
gentoo-c94009b21052097771a35b175ac5cda95bd83938.zip
dev-ruby/celluloid: add ruby24
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/celluloid')
-rw-r--r--dev-ruby/celluloid/celluloid-0.17.3.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-ruby/celluloid/celluloid-0.17.3.ebuild b/dev-ruby/celluloid/celluloid-0.17.3.ebuild
index 4db09322a87f..7e879b85be7e 100644
--- a/dev-ruby/celluloid/celluloid-0.17.3.ebuild
+++ b/dev-ruby/celluloid/celluloid-0.17.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-USE_RUBY="ruby21 ruby22 ruby23"
+USE_RUBY="ruby23 ruby24"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
# Needed by packages writing specs for celluloid
@@ -42,3 +42,11 @@ all_ruby_prepare() {
sed -i -e '1irequire "pathname"' spec/spec_helper.rb || die
mkdir log || die
}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby24)
+ sed -i -e '/String expected, but Fixnum received/ s/Fixnum/Integer/' spec/shared/actor_examples.rb || die
+ ;;
+ esac
+}