summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-02-14 07:37:39 +0100
committerHans de Graaff <graaff@gentoo.org>2020-02-14 08:18:32 +0100
commit809c29964ed250cfc0b17aa6e5d513a21f04ebfe (patch)
tree4d1a4603b05092def3b8075c4e77fc299d7d0b28 /dev-ruby/colored2/colored2-3.1.2.ebuild
parentdev-ruby/rainbow: add ruby27 (diff)
downloadgentoo-809c29964ed250cfc0b17aa6e5d513a21f04ebfe.tar.gz
gentoo-809c29964ed250cfc0b17aa6e5d513a21f04ebfe.tar.bz2
gentoo-809c29964ed250cfc0b17aa6e5d513a21f04ebfe.zip
dev-ruby/colored2: initial import of 3.1.2
New dependency for app-admin/r10k. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/colored2/colored2-3.1.2.ebuild')
-rw-r--r--dev-ruby/colored2/colored2-3.1.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/colored2/colored2-3.1.2.ebuild b/dev-ruby/colored2/colored2-3.1.2.ebuild
new file mode 100644
index 000000000000..5a158dea39ff
--- /dev/null
+++ b/dev-ruby/colored2/colored2-3.1.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Console coloring"
+HOMEPAGE="https://github.com/kigster/colored2"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+each_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+ sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+}