summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-01-07 17:59:19 +0100
committerHans de Graaff <graaff@gentoo.org>2023-01-08 08:49:41 +0100
commit4d2a3eff0241fb1e39641bc0210080c0c6de0709 (patch)
treed2bb2fb45dab0e24032019fd91c307b1f985be79 /dev-ruby/curb/curb-0.9.11-r1.ebuild
parentdev-ruby/maxitest: add 4.4.0 (diff)
downloadgentoo-4d2a3eff0241fb1e39641bc0210080c0c6de0709.tar.gz
gentoo-4d2a3eff0241fb1e39641bc0210080c0c6de0709.tar.bz2
gentoo-4d2a3eff0241fb1e39641bc0210080c0c6de0709.zip
dev-ruby/curb: drop 0.9.11-r1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/curb/curb-0.9.11-r1.ebuild')
-rw-r--r--dev-ruby/curb/curb-0.9.11-r1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-ruby/curb/curb-0.9.11-r1.ebuild b/dev-ruby/curb/curb-0.9.11-r1.ebuild
deleted file mode 100644
index 884ae6906585..000000000000
--- a/dev-ruby/curb/curb-0.9.11-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_RECIPE_TEST="rake"
-
-RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby-language bindings for libcurl"
-HOMEPAGE="https://github.com/taf2/curb"
-
-LICENSE="Ruby"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE=""
-
-DEPEND+=" net-misc/curl[ssl] test? ( net-misc/curl )"
-RDEPEND+=" net-misc/curl[ssl]"
-
-all_ruby_prepare() {
- # fix tests when localhost is also ::1
- sed -i -e 's|localhost:|127.0.0.1:|g' tests/*.rb || die
-
- # avoid tests making outside network connections
- rm tests/bug_postfields_crash.rb || die
- sed -e '/test_easy_http_verbs_must_respond_to_str/,/^ end/ s:^:#:' \
- -i tests/tc_curl_easy.rb || die
- sed -e '/test_connection_keepalive/aomit "network connection needed"' \
- -i tests/tc_curl_multi.rb || die
-
- # Fix test that expects wrong output
- sed -i -e 's/200 OK /200 OK/' tests/tc_curl_easy.rb || die
-
- # avoid failing tests where failure condition seems weird, no
- # upstream travis so not clear if the test is indeed broken.
- sed -i -e '/test_multi_easy_http/,/^ end/ s:^:#:' tests/tc_curl_multi.rb || die
-
- # avoid test requiring ntlm support on curl which is no longer available in gentoo
- sed -i -e '/test_username_password/aomit "ntlm support in curl needed"' -i tests/tc_curl_easy.rb || die
-}