summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/dust
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/dust')
-rw-r--r--dev-ruby/dust/Manifest1
-rw-r--r--dev-ruby/dust/dust-0.1.7-r1.ebuild27
-rw-r--r--dev-ruby/dust/dust-0.1.7-r2.ebuild31
-rw-r--r--dev-ruby/dust/metadata.xml5
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-ruby/dust/Manifest b/dev-ruby/dust/Manifest
new file mode 100644
index 000000000000..ac572b2b39ef
--- /dev/null
+++ b/dev-ruby/dust/Manifest
@@ -0,0 +1 @@
+DIST dust-0.1.7.gem 6656 SHA256 f4542f0cd17739a95b28ce5fcdf6ed7277e4fcce30d359f44fe95eed10289969 SHA512 f5b6d46dc4316a5c8aa49ba6122284f9ca08a491768cb5f89c6a5bfde4ff8b95df7b0234c67a27334af236801e474f27cd7cfdb0f5aaf4c65cc324977926ae1f WHIRLPOOL 49c7497eb78c086ff6831bbbf6132fda48b70a9e8879fef5a8781e4ae951aa1e2d5ed5825c6cf0793ea71d978ebb4605691a437c4a540db02a835ad51439fa5b
diff --git a/dev-ruby/dust/dust-0.1.7-r1.ebuild b/dev-ruby/dust/dust-0.1.7-r1.ebuild
new file mode 100644
index 000000000000..125fb0a1c79b
--- /dev/null
+++ b/dev-ruby/dust/dust-0.1.7-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Descriptive block syntax definition for Test::Unit"
+HOMEPAGE="http://dust.rubyforge.org/"
+LICENSE="MIT"
+
+KEYWORDS="amd64 x86"
+SLOT="0"
+IUSE=""
+
+# Remove a long-obsolete rubygems method.
+all_ruby_prepare() {
+ sed -i '/manage_gems/d' rakefile.rb || die "Unable to update rakefile.rb"
+}
+
+each_ruby_test() {
+ ${RUBY} -I. test/all_tests.rb || die
+}
diff --git a/dev-ruby/dust/dust-0.1.7-r2.ebuild b/dev-ruby/dust/dust-0.1.7-r2.ebuild
new file mode 100644
index 000000000000..8783df357caa
--- /dev/null
+++ b/dev-ruby/dust/dust-0.1.7-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Descriptive block syntax definition for Test::Unit"
+HOMEPAGE="http://dust.rubyforge.org/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+# Remove a long-obsolete rubygems method.
+all_ruby_prepare() {
+ sed -i -e '/manage_gems/d' \
+ -e '/gempackagetask/d' \
+ -e '/GemPackageTask/,/end/d' \
+ -e 's:rake/rdoctask:rdoc/task:' rakefile.rb || die "Unable to update rakefile.rb"
+
+}
+
+each_ruby_test() {
+ ${RUBY} -I. test/all_tests.rb || die
+}
diff --git a/dev-ruby/dust/metadata.xml b/dev-ruby/dust/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/dust/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>