summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/ethon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/ethon')
-rw-r--r--dev-ruby/ethon/Manifest3
-rw-r--r--dev-ruby/ethon/ethon-0.7.1.ebuild31
-rw-r--r--dev-ruby/ethon/ethon-0.7.3.ebuild33
-rw-r--r--dev-ruby/ethon/ethon-0.7.4.ebuild33
-rw-r--r--dev-ruby/ethon/metadata.xml8
5 files changed, 108 insertions, 0 deletions
diff --git a/dev-ruby/ethon/Manifest b/dev-ruby/ethon/Manifest
new file mode 100644
index 000000000000..e69a38f9b0a6
--- /dev/null
+++ b/dev-ruby/ethon/Manifest
@@ -0,0 +1,3 @@
+DIST ethon-0.7.1.gem 52224 SHA256 e62d5efaa14b85c04a9f7193d8961f4c91fd9bd5bbcc4f33950e08692b13e62c SHA512 484aa0df0e4375369c839d66f114940760ad6102a026ecc1886283c80d856ed347b8ab853a90c3ac514766a9afe7032030647b93bb030c739b308f303d483425 WHIRLPOOL 8f668649b639a06e65a59480a07487d572740b1fc303b939e971f3fce2d93e0c993b672f70aca624c9f304ced01effdec1b42fcff3324c8b9b5e3826e68779e9
+DIST ethon-0.7.3.gem 52736 SHA256 68394c21ee9f84d797aa5cfadd14cd816693b91159403af633ec3c359b26c4b4 SHA512 a37dc3c237e6af1e2b826ef2f6136ea0bb59f1b9607603d340e4d583a09beceb8b3259b4c3526639d384ea6a310ee2d3907812bfb32881842d2f3bad8c46c656 WHIRLPOOL 5f1b788fc7b82ed1a6d88c1d6f7cb624a3c0ae90b7ea4404e8b7f60fcfea243bd4530b32a7678cc0c30b6fe3224963494981f775958a2d2da88253669ef74b0b
+DIST ethon-0.7.4.gem 54272 SHA256 2670e329ff113f772448b9af8ed45fabf570f37b1dea9f68377ed056fb94ce13 SHA512 a4df7083b545d1b777e640ba238f63a939ee1db97d25f6d4be6f4a20f0e629eb3e107724a6a87da037529667130ad220f216a82c3b4044588780f5fff809f69b WHIRLPOOL a64b0573869dc4cc48eb1c6488eac065fa9b2053b3362a82af906af2c35025f318ccb0b46a8cda18e30f697dc2ec4ae9c7461c48b8afefffa4a978ce1779f930
diff --git a/dev-ruby/ethon/ethon-0.7.1.ebuild b/dev-ruby/ethon/ethon-0.7.1.ebuild
new file mode 100644
index 000000000000..861631cd5700
--- /dev/null
+++ b/dev-ruby/ethon/ethon-0.7.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Very lightweight libcurl wrapper"
+HOMEPAGE="https://github.com/typhoeus/ethon"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND+="net-misc/curl"
+
+ruby_add_rdepend ">=dev-ruby/ffi-1.3.0"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/bundler/I s:^:#:' -i Rakefile spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/ethon/ethon-0.7.3.ebuild b/dev-ruby/ethon/ethon-0.7.3.ebuild
new file mode 100644
index 000000000000..cc73b8097fe7
--- /dev/null
+++ b/dev-ruby/ethon/ethon-0.7.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Very lightweight libcurl wrapper"
+HOMEPAGE="https://github.com/typhoeus/ethon"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND+="net-misc/curl"
+
+ruby_add_rdepend ">=dev-ruby/ffi-1.3.0"
+
+ruby_add_bdepend "test? ( dev-ruby/sinatra dev-ruby/mime-types )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/bundler/I s:^:#:' -i Rakefile spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/ethon/ethon-0.7.4.ebuild b/dev-ruby/ethon/ethon-0.7.4.ebuild
new file mode 100644
index 000000000000..320dbbc2e8cb
--- /dev/null
+++ b/dev-ruby/ethon/ethon-0.7.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Very lightweight libcurl wrapper"
+HOMEPAGE="https://github.com/typhoeus/ethon"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND+=" net-misc/curl"
+
+ruby_add_rdepend ">=dev-ruby/ffi-1.3.0"
+
+ruby_add_bdepend "test? ( dev-ruby/sinatra dev-ruby/mime-types )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/bundler/I s:^:#:' -i Rakefile spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/ethon/metadata.xml b/dev-ruby/ethon/metadata.xml
new file mode 100644
index 000000000000..3e9dad2cc171
--- /dev/null
+++ b/dev-ruby/ethon/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">typhoeus/ethon</remote-id>
+ </upstream>
+</pkgmetadata>