summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-09-17 07:42:10 +0200
committerHans de Graaff <graaff@gentoo.org>2023-09-17 07:42:53 +0200
commit1de7d32c1b1698d69d333d8bbcdd8f78752b8bba (patch)
tree4875d7aeef214af8dfa2c61234e743204eabcc8f /dev-ruby/execjs/execjs-2.9.1.ebuild
parentapp-text/ghostscript-gpl: drop 10.0.0-r5, 10.01.0 (diff)
downloadgentoo-1de7d32c1b1698d69d333d8bbcdd8f78752b8bba.tar.gz
gentoo-1de7d32c1b1698d69d333d8bbcdd8f78752b8bba.tar.bz2
gentoo-1de7d32c1b1698d69d333d8bbcdd8f78752b8bba.zip
dev-ruby/execjs: add 2.9.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/execjs/execjs-2.9.1.ebuild')
-rw-r--r--dev-ruby/execjs/execjs-2.9.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/execjs/execjs-2.9.1.ebuild b/dev-ruby/execjs/execjs-2.9.1.ebuild
new file mode 100644
index 000000000000..ad23c4d39afd
--- /dev/null
+++ b/dev-ruby/execjs/execjs-2.9.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+inherit ruby-fakegem
+
+DESCRIPTION="ExecJS lets you run JavaScript code from Ruby"
+HOMEPAGE="https://github.com/rails/execjs"
+SRC_URI="https://github.com/rails/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x64-macos"
+
+IUSE="test"
+
+# execjs supports various javascript runtimes. They are listed in order
+# as per the documentation. For now only include the ones already in the
+# tree.
+
+RDEPEND+=" || ( dev-ruby/duktape-rb net-libs/nodejs )"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" Rakefile || die
+ # Avoid test requiring network connectivity. We could potentially
+ # substitute dev-ruby/coffee-script-source for this.
+ sed -i -e '/test_coffeescript/,/end/ s:^:#:' test/test_execjs.rb || die
+}