summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-09-16 11:17:23 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-09-16 11:45:48 -0500
commitb0505bc9063373e69b2895be9c37800f4562f39d (patch)
treee08042bc83e82c19b49c5d87c4a3c8c0115f24c6 /dev-ruby/facter
parentcommon-lisp-3.eclass: fix various @USAGE inconsistencies (diff)
downloadgentoo-b0505bc9063373e69b2895be9c37800f4562f39d.tar.gz
gentoo-b0505bc9063373e69b2895be9c37800f4562f39d.tar.bz2
gentoo-b0505bc9063373e69b2895be9c37800f4562f39d.zip
dev-ruby/facter: 3.14.3 stable amd64/x86 with cleanup
Package-Manager: Portage-2.3.69, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby/facter')
-rw-r--r--dev-ruby/facter/Manifest1
-rw-r--r--dev-ruby/facter/facter-3.13.2-r1.ebuild112
-rw-r--r--dev-ruby/facter/facter-3.14.3.ebuild2
3 files changed, 1 insertions, 114 deletions
diff --git a/dev-ruby/facter/Manifest b/dev-ruby/facter/Manifest
index b476b90ea8e8..8969c6bfe89c 100644
--- a/dev-ruby/facter/Manifest
+++ b/dev-ruby/facter/Manifest
@@ -1,4 +1,3 @@
-DIST facter-3.13.2.tar.gz 392065 BLAKE2B ae06a1a44de25f55b2eb84483a7abc70433b9437a00724f239a908846148f20bdb3e208d10256e6ddeb7d609ee9eb1c572e14dad84d8640fee147c34cb1bf184 SHA512 c7d1d0958720e0884b06eccf6d7fca64d2c8462c1747bbfbfe5df957ad009c3e930fe5eee80d42c985ea9f59e2b8b7d0a34a194a7e1c713a043bbee9a3b89df3
DIST facter-3.14.2.tar.gz 393499 BLAKE2B 41e8c81668580f215eb597a2130b0d9830bed4067c76d6429f54d7389767f79ef7f059b8d14d8fdf5baeeb1abdce1fa7c0ae69fee4eb221facb1cc66b9a5049b SHA512 83520da9b9739eb7f1fa72bea6765d02d92d09f20143b7c605b032cd5e720b239035c4ae9991711a0e1b9699ee074710506aa4de5f630c28c3d5c9c1a0682fb2
DIST facter-3.14.3.tar.gz 395278 BLAKE2B bda071fb92d337e2d6e58faaa33a6b135b6dfd3b6f4077af3b872bd44191629810fe99a7a1f8d9e3b16c4ff45ba587730bccb0652dcd85f4562120def42c7f38 SHA512 abd7cb3e102bff7635d6b2c17e5650e0a7b7be5ed6b81003df17053f0c9c4887f7db948714daaa313c7569bcc788ab18b0361a57395cd5118a6be38d571794df
DIST facter-3.9.2.tar.gz 380883 BLAKE2B d2804664e0499715230e5696c5a9ebae933f5b43dfb37154251d47763c2c7f78cfa8d1413dd836e5a0c76ed67300d066fa5bb390f17f85cd4cb7a444eaf0d133 SHA512 bc040826311bbff40f5a151ade315d9d47ef1e0f3faa570805e48ca55405265e66308230118b9cd59f701ecd76a7b0fd4d9200dd4ace838521223a162b105374
diff --git a/dev-ruby/facter/facter-3.13.2-r1.ebuild b/dev-ruby/facter/facter-3.13.2-r1.ebuild
deleted file mode 100644
index b9491751f31b..000000000000
--- a/dev-ruby/facter/facter-3.13.2-r1.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-# git-r3 goes after ruby-ng so that it overrides src_unpack properly
-inherit cmake-utils eutils multilib ruby-ng
-
-DESCRIPTION="A cross-platform ruby library for retrieving facts from operating systems"
-HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="debug test"
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/puppetlabs/facter.git"
- EGIT_BRANCH="master"
-else
- [[ "${PV}" = *_rc* ]] || \
- KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc x86"
- SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-BDEPEND="
- >=sys-devel/gcc-4.8:*
- dev-cpp/cpp-hocon"
-COMMON_DEPEND="
- >=dev-libs/leatherman-1.0.0:=
- dev-libs/openssl:0=
- sys-apps/util-linux
- app-emulation/virt-what
- net-misc/curl
- >=dev-libs/boost-1.54:=[nls]
- <dev-libs/boost-1.70.0
- >=dev-cpp/yaml-cpp-0.5.1
- !<app-admin/puppet-4.0.0"
-
-ruby_add_bdepend "test? ( dev-ruby/rake dev-ruby/rspec:2 dev-ruby/mocha:0.14 )"
-
-RDEPEND="${COMMON_DEPEND}"
-DEPEND="${BDEPEND}
- ${COMMON_DEPEND}"
-
-# restore ${S} and override all phases exported by ruby-ng.eclass
-S="${WORKDIR}/${P}"
-
-pkg_setup() {
- ruby-ng_pkg_setup
-}
-
-src_unpack() {
- default
-
- if [[ ${PV} == 9999 ]] ; then
- git-r3_src_unpack
- fi
-}
-
-src_prepare() {
- # be explicit about the version of rspec we test with
- sed -i -e '/libfacter.*specs/ s/rspec/rspec-2/' \
- CMakeLists.txt || die
- # be more lenient for software versions for tests
- sed -i -e '/rake/ s/~> 10.1.0/>= 10/' \
- -e '/rspec/ s/2.11.0/2.11/' \
- -e '/mocha/ s/0.10.5/0.14.0/' lib/Gemfile || die
- # patches
- default
- cmake-utils_src_prepare
-}
-
-each_ruby_configure() {
- # hack for correct calculation of relative path from facter.rb to
- # libfacter.so
- my_ruby_sitelibdir=$(ruby_rbconfig_value 'sitelibdir')
-}
-
-src_configure() {
- ruby-ng_src_configure
-
- local mycmakeargs=(
- -DCMAKE_VERBOSE_MAKEFILE=ON
- -DRUBY_LIB_INSTALL=${my_ruby_sitelibdir}
- -DBLKID_LIBRARYDIR="${EPREFIX}/$(get_libdir)"
- )
- if use debug; then
- mycmakeargs+=(
- -DCMAKE_BUILD_TYPE=Debug
- )
- fi
- cmake-utils_src_configure
-}
-
-src_compile() {
- addpredict /proc/self/oom_score_adj
- cmake-utils_src_compile
-}
-
-src_test() {
- cmake-utils_src_test
-}
-
-each_ruby_install() {
- doruby "${BUILD_DIR}"/lib/facter.rb
-}
-
-src_install() {
- cmake-utils_src_install
- ruby-ng_src_install
-}
diff --git a/dev-ruby/facter/facter-3.14.3.ebuild b/dev-ruby/facter/facter-3.14.3.ebuild
index 4c7110c0cf6d..b9491751f31b 100644
--- a/dev-ruby/facter/facter-3.14.3.ebuild
+++ b/dev-ruby/facter/facter-3.14.3.ebuild
@@ -19,7 +19,7 @@ if [[ ${PV} == 9999 ]] ; then
EGIT_BRANCH="master"
else
[[ "${PV}" = *_rc* ]] || \
- KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+ KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc x86"
SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
fi