summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/fast_gettext
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/fast_gettext')
-rw-r--r--dev-ruby/fast_gettext/Manifest2
-rw-r--r--dev-ruby/fast_gettext/fast_gettext-0.9.0.ebuild56
-rw-r--r--dev-ruby/fast_gettext/fast_gettext-0.9.2.ebuild48
-rw-r--r--dev-ruby/fast_gettext/metadata.xml8
4 files changed, 114 insertions, 0 deletions
diff --git a/dev-ruby/fast_gettext/Manifest b/dev-ruby/fast_gettext/Manifest
new file mode 100644
index 000000000000..504347510d96
--- /dev/null
+++ b/dev-ruby/fast_gettext/Manifest
@@ -0,0 +1,2 @@
+DIST fast_gettext-0.9.0.tar.gz 86616 SHA256 773f1112524f1777f4f46ce80c5e1341dd270d232d86808d5ecc27d5b4d83e29 SHA512 901e9725ae537300be078febf4c5c94f466da48b0e4d3611037bfc98b914436a23828708177d6874c7b2ae60245631cd414ee52bd1b9de90c6ff8d1a6dbe37a4 WHIRLPOOL 06f858d501d66cfc609ff2a75010e73b33f706d388286a64ce923a6a87f96ddcc98a6623644b8bac9e57dbe86b7345ddd7aaf601d69ca600e6f8a7c9c8e95114
+DIST fast_gettext-0.9.2.tar.gz 86892 SHA256 7c7de3f9ac19d2e5a81fa15bf0dcd4d54bcb92051e881d83265c6cdadfce239b SHA512 d8bfe755ba6754ff474a6d0e42e9a725aa00f20b381fe5c0a2a2dc3efc5e0bf6096450e0665cd4369717296dc55cd316f836d9cd35b96764eb56e3ca33379c14 WHIRLPOOL 615f5357815d8321d1f099889b352826034af1defbf8a6a4383b9e71b7e37ed06c582e0e957ec4e9a2345b3b84dce9a5432e3d85946f679fa27fcafe04cbce4c
diff --git a/dev-ruby/fast_gettext/fast_gettext-0.9.0.ebuild b/dev-ruby/fast_gettext/fast_gettext-0.9.0.ebuild
new file mode 100644
index 000000000000..07231d74d683
--- /dev/null
+++ b/dev-ruby/fast_gettext/fast_gettext-0.9.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# jruby support requires sqlite3 support for jruby.
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG Readme.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="GetText but 3.5 x faster, 560 x less memory, simple, clean namespace (7 vs 34) and threadsave!"
+HOMEPAGE="https://github.com/grosser/fast_gettext"
+SRC_URI="https://github.com/grosser/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/activerecord dev-ruby/protected_attributes dev-ruby/bundler )"
+
+all_ruby_prepare() {
+ rm Gemfile.lock || die
+
+ # Remove jeweler and bump from Gemfile since they are not needed for tests.
+ sed -i -e '/jeweler/d' -e '/bump/d' -e '/appraisal/d' Gemfile || die
+
+ # Avoid unneeded dependency on git and development dependencies.
+ sed -e '/git ls-files/ s:^:#:' \
+ -e '/\(wwtd\|bump\)/ s:^:#:' \
+ -i fast_gettext.gemspec || die
+
+ # Don't run a test that requires safe mode which we can't provide
+ # due to insecure directory settings for the portage dir. This spec
+ # also calls out to ruby which won't work with different ruby
+ # implementations.
+ sed -i -e '/can work in SAFE mode/,/^ end/ s:^:#:' spec/fast_gettext/translation_repository/mo_spec.rb || die
+
+ # Avoid not failing pending specs related to ree18.
+ sed -i -e '/with i18n loaded/,/^ end/ s:^:#:' spec/fast_gettext/vendor/string_spec.rb || die
+
+ # Avoid RSpec 3 specific syntax
+ sed -e '/failure_message/ s:^:#:' -i spec/support/be_accessible_matcher.rb || die
+
+}
+
+each_ruby_prepare() {
+ # Make sure the right ruby interpreter is used
+ sed -i -e "s:bundle exec ruby:bundle exec ${RUBY}:" spec/fast_gettext/vendor/*spec.rb || die
+}
diff --git a/dev-ruby/fast_gettext/fast_gettext-0.9.2.ebuild b/dev-ruby/fast_gettext/fast_gettext-0.9.2.ebuild
new file mode 100644
index 000000000000..ef29405f1ba9
--- /dev/null
+++ b/dev-ruby/fast_gettext/fast_gettext-0.9.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG Readme.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="GetText but 3.5 x faster, 560 x less memory, simple, clean namespace (7 vs 34) and threadsave!"
+HOMEPAGE="https://github.com/grosser/fast_gettext"
+SRC_URI="https://github.com/grosser/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/activerecord dev-ruby/protected_attributes dev-ruby/bundler )"
+
+all_ruby_prepare() {
+ rm Gemfile.lock || die
+
+ # Remove jeweler and bump from Gemfile since they are not needed for tests.
+ sed -i -e '/jeweler/d' -e '/bump/d' -e '/appraisal/d' Gemfile || die
+
+ # Avoid unneeded dependency on git and development dependencies.
+ sed -e '/git ls-files/ s:^:#:' \
+ -e '/\(wwtd\|bump\)/ s:^:#:' \
+ -i fast_gettext.gemspec || die
+
+ # Don't run a test that requires safe mode which we can't provide
+ # due to insecure directory settings for the portage dir. This spec
+ # also calls out to ruby which won't work with different ruby
+ # implementations.
+ sed -i -e '/can work in SAFE mode/,/^ end/ s:^:#:' spec/fast_gettext/translation_repository/mo_spec.rb || die
+}
+
+each_ruby_prepare() {
+ # Make sure the right ruby interpreter is used
+ sed -i -e "s:bundle exec ruby:bundle exec ${RUBY}:" spec/fast_gettext/vendor/*spec.rb || die
+}
diff --git a/dev-ruby/fast_gettext/metadata.xml b/dev-ruby/fast_gettext/metadata.xml
new file mode 100644
index 000000000000..40aa9618736c
--- /dev/null
+++ b/dev-ruby/fast_gettext/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">grosser/fast_gettext</remote-id>
+ </upstream>
+</pkgmetadata>