summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-06-10 10:58:52 +0200
committerHans de Graaff <graaff@gentoo.org>2016-06-10 10:59:34 +0200
commitf37ae6400175ab3722f240e8c8d6a7fb5b69f897 (patch)
treee4b32def13fc2d26b8598e8df9b8108e43c30a37 /dev-ruby/hiera-eyaml/hiera-eyaml-2.1.0.ebuild
parentdev-ruby/github_api: add 0.14.0 (diff)
downloadgentoo-f37ae6400175ab3722f240e8c8d6a7fb5b69f897.tar.gz
gentoo-f37ae6400175ab3722f240e8c8d6a7fb5b69f897.tar.bz2
gentoo-f37ae6400175ab3722f240e8c8d6a7fb5b69f897.zip
dev-ruby/hiera-eyaml: add 2.1.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/hiera-eyaml/hiera-eyaml-2.1.0.ebuild')
-rw-r--r--dev-ruby/hiera-eyaml/hiera-eyaml-2.1.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/hiera-eyaml/hiera-eyaml-2.1.0.ebuild b/dev-ruby/hiera-eyaml/hiera-eyaml-2.1.0.ebuild
new file mode 100644
index 000000000000..e0bfa8e865bc
--- /dev/null
+++ b/dev-ruby/hiera-eyaml/hiera-eyaml-2.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGES.md PLUGINS.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Encrypted YAML backend for hiera"
+HOMEPAGE="https://github.com/TomPoulton/hiera-eyaml"
+SRC_URI="https://github.com/TomPoulton/hiera-eyaml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/highline-1.6.19"
+ruby_add_rdepend "dev-ruby/trollop:2"
+
+ruby_add_bdepend "test? ( dev-util/cucumber =dev-util/aruba-0.6.2 app-admin/puppet dev-ruby/hiera-eyaml-plaintext )"
+
+all_ruby_prepare() {
+ # Fix highline dependency to be compatible with more versions.
+ sed -i -e '/highline/ s/~>/>=/' \
+ -e '/gem.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i -e 's:/tmp:'${T}':' \
+ features/sandbox/puppet/environments/local/modules/test/manifests/init.pp \
+ features/sandbox/puppet-hiera-merge/environments/local/modules/test/manifests/init.pp \
+ features/puppet.feature
+}
+
+each_ruby_test() {
+ ${RUBY} -S cucumber --format progress features || die
+}