summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/hiera
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/hiera')
-rw-r--r--dev-ruby/hiera/Manifest3
-rw-r--r--dev-ruby/hiera/hiera-1.3.4-r1.ebuild32
-rw-r--r--dev-ruby/hiera/hiera-1.3.4.ebuild32
-rw-r--r--dev-ruby/hiera/hiera-2.0.0.ebuild32
-rw-r--r--dev-ruby/hiera/hiera-3.0.1-r1.ebuild33
-rw-r--r--dev-ruby/hiera/metadata.xml9
6 files changed, 141 insertions, 0 deletions
diff --git a/dev-ruby/hiera/Manifest b/dev-ruby/hiera/Manifest
new file mode 100644
index 000000000000..ca93327faf62
--- /dev/null
+++ b/dev-ruby/hiera/Manifest
@@ -0,0 +1,3 @@
+DIST hiera-1.3.4.gem 30208 SHA256 a3c85385ddda64916d453efeeb965151dc2454428d88f04f40d539559af27020 SHA512 be3b702f0e3c2e61d8d6a8c1ff1280f9a1be3dc4adc2a605b4ee3b5db82d513bd58fb6b22ef546a625cf4eefa43d597365187b776ee92c2dd9946eaa4b147128 WHIRLPOOL 27334cb8b3aef8cd40eb74933fac99e30a5eda7770e980093092465f2eaf7e1e714e47428e3b585fc67f490b91eb4c22fd42ac66110b8cf6365650ace00840c8
+DIST hiera-2.0.0.gem 35840 SHA256 1645de864b7d59af2482f11b84aabe015121b2a9947d1816623ea0dd2c7385f8 SHA512 153f75d4c6dd45920841c065f3f4808b28a30d1e0370a8a96866d20451b225e9434017134c48d96fc244cfeca5fdbaa8f325225644d5b151933bb45383d64a23 WHIRLPOOL 74807775fdccbeda4786ba629288e0fc8101ebec749c18c1e01ffc7cb8d2c4fa818427bc2b88892bea7b3a9b41e9a2b813de03cae84522dfcc9c804af15d8c44
+DIST hiera-3.0.1.gem 35328 SHA256 8e0c8f1f9fc2200c7a5d4a5d70c7b1524f071d41cb1b0667f4398a0601954acc SHA512 bd71b3df67a416193bb38dbf4f744f8266f2f6eb8dbddaf329d8c25d809a2f3f1dee474545b2f1a1bafecaf630b476e29f2e53e20598c77b0db12c6875be8ee6 WHIRLPOOL 94e1e0b7e8da1b72ceae09ebb9f5f4dead13f8b7a85749240a4ba372e0cbfc70b68e118dd92dad0218b85e775713de551a2997d9b3d2e5a120e641de4bdf9508
diff --git a/dev-ruby/hiera/hiera-1.3.4-r1.ebuild b/dev-ruby/hiera/hiera-1.3.4-r1.ebuild
new file mode 100644
index 000000000000..094944b954c4
--- /dev/null
+++ b/dev-ruby/hiera/hiera-1.3.4-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple pluggable Hierarchical Database"
+HOMEPAGE="http://projects.puppetlabs.com/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+ruby_add_rdepend "dev-ruby/json"
+
+all_ruby_prepare() {
+ # Our json package is either the compiled version or the pure
+ # version. Fix gemspec accordingly.
+ sed -i -e 's/json_pure/json/' ../metadata || die
+}
diff --git a/dev-ruby/hiera/hiera-1.3.4.ebuild b/dev-ruby/hiera/hiera-1.3.4.ebuild
new file mode 100644
index 000000000000..d4a330a658a0
--- /dev/null
+++ b/dev-ruby/hiera/hiera-1.3.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple pluggable Hierarchical Database"
+HOMEPAGE="http://projects.puppetlabs.com/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 hppa ppc sparc x86"
+
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+ruby_add_rdepend "dev-ruby/json"
+
+all_ruby_prepare() {
+ # Our json package is either the compiled version or the pure
+ # version. Fix gemspec accordingly.
+ sed -i -e 's/json_pure/json/' ../metadata || die
+}
diff --git a/dev-ruby/hiera/hiera-2.0.0.ebuild b/dev-ruby/hiera/hiera-2.0.0.ebuild
new file mode 100644
index 000000000000..d9c0eeff6e8a
--- /dev/null
+++ b/dev-ruby/hiera/hiera-2.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple pluggable Hierarchical Database"
+HOMEPAGE="http://projects.puppetlabs.com/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+ruby_add_rdepend "dev-ruby/json"
+
+all_ruby_prepare() {
+ # Our json package is either the compiled version or the pure
+ # version. Fix gemspec accordingly.
+ sed -i -e 's/json_pure/json/' ../metadata || die
+}
diff --git a/dev-ruby/hiera/hiera-3.0.1-r1.ebuild b/dev-ruby/hiera/hiera-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..13a8945c624e
--- /dev/null
+++ b/dev-ruby/hiera/hiera-3.0.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple pluggable Hierarchical Database"
+HOMEPAGE="http://projects.puppetlabs.com/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~hppa ~x86"
+
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+ruby_add_rdepend "dev-ruby/json
+ dev-ruby/deep_merge"
+
+all_ruby_prepare() {
+ # Our json package is either the compiled version or the pure
+ # version. Fix gemspec accordingly.
+ sed -i -e 's/json_pure/json/' ../metadata || die
+}
diff --git a/dev-ruby/hiera/metadata.xml b/dev-ruby/hiera/metadata.xml
new file mode 100644
index 000000000000..7f9678c1dfef
--- /dev/null
+++ b/dev-ruby/hiera/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>prometheanfire@gentoo.org</email>
+</maintainer>
+<herd>sysadmin</herd>
+<herd>ruby</herd>
+</pkgmetadata>