summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-04-28 08:18:37 +0200
committerHans de Graaff <graaff@gentoo.org>2018-04-28 08:32:35 +0200
commitbbb9bfb8fb31ba978eb0d67edc22e7120fd6fd73 (patch)
tree39cb1efaf3c64ee022ac8a05f542479cbbd9e30e /dev-ruby/http/http-2.2.1.ebuild
parentdev-ruby/rb-inotify: depend directly on ffi and add ruby25 (diff)
downloadgentoo-bbb9bfb8fb31ba978eb0d67edc22e7120fd6fd73.tar.gz
gentoo-bbb9bfb8fb31ba978eb0d67edc22e7120fd6fd73.tar.bz2
gentoo-bbb9bfb8fb31ba978eb0d67edc22e7120fd6fd73.zip
dev-ruby/http: cleanup
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/http/http-2.2.1.ebuild')
-rw-r--r--dev-ruby/http/http-2.2.1.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-ruby/http/http-2.2.1.ebuild b/dev-ruby/http/http-2.2.1.ebuild
deleted file mode 100644
index 14eb329cb4c0..000000000000
--- a/dev-ruby/http/http-2.2.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby21 ruby22 ruby23"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="An easy-to-use client library for making requests from Ruby"
-HOMEPAGE="https://github.com/tarcieri/http"
-
-LICENSE="MIT"
-SLOT="2.0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/addressable-2.3
- >=dev-ruby/http-cookie-1.0
- >=dev-ruby/http-form_data-1.0.1:1.0
- >=dev-ruby/http_parser_rb-0.6.0 =dev-ruby/http_parser_rb-0.6*"
-
-ruby_add_bdepend "
- test? ( dev-ruby/certificate_authority dev-ruby/rspec-its )"
-
-all_ruby_prepare() {
- sed -i -e '/simplecov/,/end/ s:^:#:' \
- -e '1irequire "cgi"' spec/spec_helper.rb || die
-
- # Avoid specs that require network access
- sed -i -e '/.persistent/,/^ end/ s:^:#:' \
- spec/lib/http_spec.rb || die
- sed -i -e '/with non-ASCII URLs/,/^ end/ s:^:#:' \
- spec/lib/http/client_spec.rb || die
-
- # Avoid spec that may fail with a running web server
- sed -i -e '/unifies socket errors into HTTP::ConnectionError/,/^ end/ s:^:#:' spec/lib/http_spec.rb || die
-}