summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/inifile
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/inifile')
-rw-r--r--dev-ruby/inifile/Manifest2
-rw-r--r--dev-ruby/inifile/inifile-2.0.2-r1.ebuild27
-rw-r--r--dev-ruby/inifile/inifile-3.0.0.ebuild27
-rw-r--r--dev-ruby/inifile/metadata.xml8
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-ruby/inifile/Manifest b/dev-ruby/inifile/Manifest
new file mode 100644
index 000000000000..9217c3d3549c
--- /dev/null
+++ b/dev-ruby/inifile/Manifest
@@ -0,0 +1,2 @@
+DIST inifile-2.0.2.gem 15360 SHA256 454c96efe281df380b6571aad5e642252916933087c12f1a943ada6c3b53370f SHA512 769b4cab1d91ff70f49a97fdb1707db4c5c1f38a695b2d47adc60dfb6cf60dd86a34f67f33ebe32f5a74af901180d90d91616ef7667bcf3b403d4edfc253267a WHIRLPOOL bebd62caedf9b53003ded3b2bb5d361a4e670caf77cb6ff9aea736e6de7b2893fc34c8fecc61ecf4c49735c823d4178d5919ea5b4a09f6c9035c146470a9cd13
+DIST inifile-3.0.0.gem 18432 SHA256 b103eb3655ec93cc626cf2de00950e91f7e69b8398842968e17e1815cfacbfb0 SHA512 d77344812bb62a5639b0a36e5ac2726280990210000b85bab700819fe0fb9f56415517c00436d0056ca090e3d568596bc30f8ed211a00aced5b929e534d0a72b WHIRLPOOL 2d1d30307508c5b9935e246d3e8832b93f84547884f86434c014bed433af0895235ff472ed7af6a584bc9a5533d4dc8296cdfd673cff1d1fead339ed73e4890c
diff --git a/dev-ruby/inifile/inifile-2.0.2-r1.ebuild b/dev-ruby/inifile/inifile-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..ac9a35b7238a
--- /dev/null
+++ b/dev-ruby/inifile/inifile-2.0.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Native Ruby package for reading and writing INI files"
+HOMEPAGE="https://github.com/TwP/inifile"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} -S testrb test/test_*.rb || die
+}
diff --git a/dev-ruby/inifile/inifile-3.0.0.ebuild b/dev-ruby/inifile/inifile-3.0.0.ebuild
new file mode 100644
index 000000000000..e518b03effb7
--- /dev/null
+++ b/dev-ruby/inifile/inifile-3.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Native Ruby package for reading and writing INI files"
+HOMEPAGE="https://github.com/TwP/inifile"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} -S testrb test/test_*.rb || die
+}
diff --git a/dev-ruby/inifile/metadata.xml b/dev-ruby/inifile/metadata.xml
new file mode 100644
index 000000000000..aea488bb9c0c
--- /dev/null
+++ b/dev-ruby/inifile/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">TwP/inifile</remote-id>
+ </upstream>
+</pkgmetadata>