summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/liquid
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/liquid')
-rw-r--r--dev-ruby/liquid/Manifest3
-rw-r--r--dev-ruby/liquid/liquid-2.6.2.ebuild27
-rw-r--r--dev-ruby/liquid/liquid-3.0.4.ebuild23
-rw-r--r--dev-ruby/liquid/liquid-3.0.6.ebuild23
-rw-r--r--dev-ruby/liquid/metadata.xml8
5 files changed, 84 insertions, 0 deletions
diff --git a/dev-ruby/liquid/Manifest b/dev-ruby/liquid/Manifest
new file mode 100644
index 000000000000..d4a02527cfc4
--- /dev/null
+++ b/dev-ruby/liquid/Manifest
@@ -0,0 +1,3 @@
+DIST liquid-2.6.2.gem 46592 SHA256 eb3b8b674f0b2b0960a9a126ad83d2e35cc4df32ab5d0cc7dee75bfef5e9f4cc SHA512 bd369fe2e9bd89013f9bbd4a7f721b2db4376ac02c5ea4b4da6a08fa6af24fe782fae38b32d250edde548980f042c7187a673da47fa8d5569ed0959fd1569827 WHIRLPOOL 29c48155c7e43c0fd0ec7c3a61960b7fcfee322dbce4e6faf85c25cd75afa0c99e4504027524f92aa9c958be874ffa021c4228174fd1154f01772a3259bd2232
+DIST liquid-3.0.4.tar.gz 87961 SHA256 64158e49f7ee8be1ac0f09b444ccf842c012d3f4bd25337360314383a62edcbf SHA512 e11774856cbaf77950e362b9bf789eaa3cbd879dbd9857867819e018ca22d5bd98db28f1cb197ec9b19e67d6f698e0ca336b092719f561e12d1c68c387ea3171 WHIRLPOOL 10a77f07582d415de454f18dd660dd05cf38e60919d125b686198477852c810402c0014a4bb1ea5d6e1ac38394c9d79cfde424547efe5484a863fe5c19fbd5aa
+DIST liquid-3.0.6.tar.gz 88159 SHA256 c9b69afa97fe1caad78452b43dc5757ebd0f4363dd6bee1e04f22179f0e43ed8 SHA512 66e1be904f3dcd18e345bf3fedf314fdf4ae84a0e1354859ee8e33f82386e929b4c871ec3c37c2c752358d76017fb5b1fef59f4bad04d3e7e89672146a3f8229 WHIRLPOOL b72ac268e6216f5eb3c1834bd0c164879dd816d79b4973ead8cc2ece71435105ed6173214a25bbe224b302a150e3309584fec5439af23841f3e631811f0f25f1
diff --git a/dev-ruby/liquid/liquid-2.6.2.ebuild b/dev-ruby/liquid/liquid-2.6.2.ebuild
new file mode 100644
index 000000000000..151ebf942a90
--- /dev/null
+++ b/dev-ruby/liquid/liquid-2.6.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="History.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Template engine for Ruby"
+HOMEPAGE="http://www.liquidmarkup.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib:test test/liquid/*_test.rb
+}
diff --git a/dev-ruby/liquid/liquid-3.0.4.ebuild b/dev-ruby/liquid/liquid-3.0.4.ebuild
new file mode 100644
index 000000000000..24f8b98b44d9
--- /dev/null
+++ b/dev-ruby/liquid/liquid-3.0.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="History.md README.md"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/Shopify/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="Template engine for Ruby"
+HOMEPAGE="http://www.liquidmarkup.org/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest
+ dev-ruby/spy )"
diff --git a/dev-ruby/liquid/liquid-3.0.6.ebuild b/dev-ruby/liquid/liquid-3.0.6.ebuild
new file mode 100644
index 000000000000..24f8b98b44d9
--- /dev/null
+++ b/dev-ruby/liquid/liquid-3.0.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="History.md README.md"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/Shopify/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="Template engine for Ruby"
+HOMEPAGE="http://www.liquidmarkup.org/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest
+ dev-ruby/spy )"
diff --git a/dev-ruby/liquid/metadata.xml b/dev-ruby/liquid/metadata.xml
new file mode 100644
index 000000000000..b3fb12e15b96
--- /dev/null
+++ b/dev-ruby/liquid/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">Shopify/liquid</remote-id>
+ </upstream>
+</pkgmetadata>