summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-05-31 10:08:38 +0200
committerHans de Graaff <graaff@gentoo.org>2020-05-31 10:08:55 +0200
commitf90fb72bba0504467c243710de56ffe52e3d0ba8 (patch)
tree91dd2296422670f41d0f02b5066d0a8097375342 /dev-ruby/oauth
parentdev-ruby/neovim-ruby-client: cleanup (diff)
downloadgentoo-f90fb72bba0504467c243710de56ffe52e3d0ba8.tar.gz
gentoo-f90fb72bba0504467c243710de56ffe52e3d0ba8.tar.bz2
gentoo-f90fb72bba0504467c243710de56ffe52e3d0ba8.zip
dev-ruby/oauth: fix tests
Closes: https://bugs.gentoo.org/723930 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/oauth')
-rw-r--r--dev-ruby/oauth/oauth-0.5.4.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-ruby/oauth/oauth-0.5.4.ebuild b/dev-ruby/oauth/oauth-0.5.4.ebuild
index d674b5571b49..59a71726716a 100644
--- a/dev-ruby/oauth/oauth-0.5.4.ebuild
+++ b/dev-ruby/oauth/oauth-0.5.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -21,16 +21,19 @@ KEYWORDS="~amd64 ~ppc ~x86 ~x86-macos"
IUSE=""
ruby_add_bdepend "test? (
+ dev-ruby/bundler
dev-ruby/test-unit:2
dev-ruby/mocha:1.0
dev-ruby/webmock
dev-ruby/rack
dev-ruby/actionpack:5.2
+ dev-ruby/railties:5.2
)"
all_ruby_prepare() {
# Require a compatible version of mocha
- sed -i -e '1igem "mocha", "~> 1.0"; gem "actionpack", "~>5.2.0"' \
+ sed -i -e '1igem "mocha", "~> 1.0"; gem "railties", "~>5.2.0" ; gem "actionpack", "~>5.2.0"' \
-e '2i gem "test-unit"; require "test/unit"' \
+ -e '/mocha/ s/mini_test/minitest/' \
-e '/\(byebug\|minitest_helpers\|simplecov\)/I s:^:#:' test/test_helper.rb || die
}