summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-08-05 22:15:47 +0200
committerHans de Graaff <graaff@gentoo.org>2018-08-05 22:36:44 +0200
commitfe02d7336a62bbf848a94eed674d6b068078343d (patch)
treefd9c395e9cf981c5c2d011877c647236cfdaf9a7 /dev-ruby/oauth
parentdev-ruby/axiom-types: add ruby25 (diff)
downloadgentoo-fe02d7336a62bbf848a94eed674d6b068078343d.tar.gz
gentoo-fe02d7336a62bbf848a94eed674d6b068078343d.tar.bz2
gentoo-fe02d7336a62bbf848a94eed674d6b068078343d.zip
dev-ruby/oauth: add ruby25
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/oauth')
-rw-r--r--dev-ruby/oauth/oauth-0.5.4.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-ruby/oauth/oauth-0.5.4.ebuild b/dev-ruby/oauth/oauth-0.5.4.ebuild
index 1b883606f56..fd90e9faa80 100644
--- a/dev-ruby/oauth/oauth-0.5.4.ebuild
+++ b/dev-ruby/oauth/oauth-0.5.4.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-USE_RUBY="ruby22 ruby23 ruby24"
+USE_RUBY="ruby23 ruby24 ruby25"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
@@ -25,12 +25,12 @@ ruby_add_bdepend "test? (
dev-ruby/mocha:1.0
dev-ruby/webmock
dev-ruby/rack
- dev-ruby/actionpack:5.1
+ dev-ruby/actionpack:5.2
)"
all_ruby_prepare() {
# Require a compatible version of mocha
- sed -i -e '1igem "mocha", "~> 1.0"; gem "actionpack", "~>5.1.0"' \
+ sed -i -e '1igem "mocha", "~> 1.0"; gem "actionpack", "~>5.2.0"' \
-e '2i gem "test-unit"; require "test/unit"' \
-e '/\(byebug\|minitest_helpers\|simplecov\)/I s:^:#:' test/test_helper.rb || die
}