summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-02-10 08:04:42 +0100
committerHans de Graaff <graaff@gentoo.org>2019-02-10 08:25:22 +0100
commitf37ffb8dbe8a36aab7c50aff816141fab25a5f88 (patch)
tree9c6cdeb33ca18c1bd5df02fbacd0b3b3cba55382 /dev-ruby/puppet_forge
parentdev-ruby/puppet_forge: fix minitar dep and install locales (diff)
downloadgentoo-f37ffb8dbe8a36aab7c50aff816141fab25a5f88.tar.gz
gentoo-f37ffb8dbe8a36aab7c50aff816141fab25a5f88.tar.bz2
gentoo-f37ffb8dbe8a36aab7c50aff816141fab25a5f88.zip
dev-ruby/puppet_forge: cleanup broken version
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/puppet_forge')
-rw-r--r--dev-ruby/puppet_forge/puppet_forge-2.2.9.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-ruby/puppet_forge/puppet_forge-2.2.9.ebuild b/dev-ruby/puppet_forge/puppet_forge-2.2.9.ebuild
deleted file mode 100644
index e343cdbdd5dc..000000000000
--- a/dev-ruby/puppet_forge/puppet_forge-2.2.9.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Tools to access Forge API information on Modules, Users, and Releases"
-HOMEPAGE="https://github.com/puppetlabs/forge-ruby"
-
-LICENSE="Apache-2.0"
-SLOT="2"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/faraday-0.9.0:0
- >=dev-ruby/faraday_middleware-0.9.0:0
- >=dev-ruby/gettext-setup-0.11:0
- dev-ruby/archive-tar-minitar
- =dev-ruby/semantic_puppet-1*
-"
-
-all_ruby_prepare() {
- # Avoid integration and user specs since they all require network access
- rm -rf spec/integration spec/unit/forge/v3/user_spec.rb || die
-
- # Fix overly restrictive dependencies
- sed -i \
- -e '/faraday/ s/0.14.0/0.99.0/' \
- -e '/faraday_middleware/ s/0.13.0/0.99.0/' \
- ${RUBY_FAKEGEM_GEMSPEC} || die
-}