summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-12-28 10:21:47 +0100
committerHans de Graaff <graaff@gentoo.org>2020-12-28 10:21:54 +0100
commit8f7e51ac48ff0e96d8631207263d31e36a6c8c16 (patch)
tree991f340d6566ac381b4627f6536ff3256677534a /dev-ruby/racc/racc-1.5.2.ebuild
parentapp-doc/tldp-howto: mark ALLARCHES (diff)
downloadgentoo-8f7e51ac48ff0e96d8631207263d31e36a6c8c16.tar.gz
gentoo-8f7e51ac48ff0e96d8631207263d31e36a6c8c16.tar.bz2
gentoo-8f7e51ac48ff0e96d8631207263d31e36a6c8c16.zip
dev-ruby/racc: avoid dep on bundler
bundler is a PDEPEND of dev-lang/ruby, but so it racc, so just avoid this dependency to make bootstrapping easier. Closes: https://bugs.gentoo.org/762181 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/racc/racc-1.5.2.ebuild')
-rw-r--r--dev-ruby/racc/racc-1.5.2.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-ruby/racc/racc-1.5.2.ebuild b/dev-ruby/racc/racc-1.5.2.ebuild
index b7494318c8dd..4460880e8ea3 100644
--- a/dev-ruby/racc/racc-1.5.2.ebuild
+++ b/dev-ruby/racc/racc-1.5.2.ebuild
@@ -40,6 +40,9 @@ all_ruby_prepare() {
# Avoid isolation since dependencies are not properly declared.
sed -i -e 's/, :isolate//' Rakefile || die
+ # Avoid bundler dependency to make bootstrapping easier
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+
sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
}