summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-06-10 09:20:26 +0200
committerHans de Graaff <graaff@gentoo.org>2019-06-10 09:26:19 +0200
commitba8d56d7417a537047b1b142b2521b35503765d2 (patch)
tree3ff5abb487a88017deb20c832927c98e75e9f875 /dev-ruby/rdoc
parentnet-vpn/libreswan: backport XFRM detection patch (diff)
downloadgentoo-ba8d56d7417a537047b1b142b2521b35503765d2.tar.gz
gentoo-ba8d56d7417a537047b1b142b2521b35503765d2.tar.bz2
gentoo-ba8d56d7417a537047b1b142b2521b35503765d2.zip
dev-ruby/rdoc: use ruby_get_use_implementations
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/rdoc')
-rw-r--r--dev-ruby/rdoc/rdoc-5.1.0.ebuild2
-rw-r--r--dev-ruby/rdoc/rdoc-6.1.1.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/dev-ruby/rdoc/rdoc-5.1.0.ebuild b/dev-ruby/rdoc/rdoc-5.1.0.ebuild
index 1b257b6fa262..fc8b7303f2dc 100644
--- a/dev-ruby/rdoc/rdoc-5.1.0.ebuild
+++ b/dev-ruby/rdoc/rdoc-5.1.0.ebuild
@@ -75,7 +75,7 @@ all_ruby_install() {
for bin in rdoc ri; do
ruby_fakegem_binwrapper $bin /usr/bin/$bin-2
- for version in ${USE_RUBY}; do
+ for version in $(ruby_get_use_implementations); do
version=`echo ${version} | cut -c 5-`
if use ruby_targets_ruby${version}; then
ruby_fakegem_binwrapper $bin /usr/bin/${bin}${version}
diff --git a/dev-ruby/rdoc/rdoc-6.1.1.ebuild b/dev-ruby/rdoc/rdoc-6.1.1.ebuild
index bf1ec0e7f4df..111d431e3e63 100644
--- a/dev-ruby/rdoc/rdoc-6.1.1.ebuild
+++ b/dev-ruby/rdoc/rdoc-6.1.1.ebuild
@@ -76,7 +76,7 @@ all_ruby_install() {
for bin in rdoc ri; do
ruby_fakegem_binwrapper $bin /usr/bin/$bin-2
- for version in ${USE_RUBY}; do
+ for version in $(ruby_get_use_implementations); do
version=`echo ${version} | cut -c 5-`
if use ruby_targets_ruby${version}; then
ruby_fakegem_binwrapper $bin /usr/bin/${bin}${version}