summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-11-25 11:09:12 +0100
committerHans de Graaff <graaff@gentoo.org>2016-11-25 11:09:12 +0100
commite17c96093f8e96506d5d8e816f489e51491ca3e0 (patch)
treea4bdb5df192f2291e286561ccbd7e1f07fc6812a /dev-ruby/redcloth
parentdev-ruby/mocha: drop stable ia64, sparc keywords, bug 576630 (diff)
downloadgentoo-e17c96093f8e96506d5d8e816f489e51491ca3e0.tar.gz
gentoo-e17c96093f8e96506d5d8e816f489e51491ca3e0.tar.bz2
gentoo-e17c96093f8e96506d5d8e816f489e51491ca3e0.zip
dev-ruby/redcloth: drop stable ia64, sparc keywords, bug 576630
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/redcloth')
-rw-r--r--dev-ruby/redcloth/redcloth-4.2.9-r3.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/dev-ruby/redcloth/redcloth-4.2.9-r3.ebuild b/dev-ruby/redcloth/redcloth-4.2.9-r3.ebuild
deleted file mode 100644
index b16082bc0f74..000000000000
--- a/dev-ruby/redcloth/redcloth-4.2.9-r3.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-USE_RUBY="ruby20"
-
-RUBY_FAKEGEM_NAME="RedCloth"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGELOG"
-
-RUBY_FAKEGEM_REQUIRE_PATHS="lib/case_sensitive_require"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="A module for using Textile in Ruby"
-HOMEPAGE="http://redcloth.org/"
-
-GITHUB_USER=jgarber
-SRC_URI="https://github.com/${GITHUB_USER}/redcloth/tarball/v${PV} -> ${RUBY_FAKEGEM_NAME}-git-${PV}.tgz"
-RUBY_S="${GITHUB_USER}-${PN}-*"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND+=" dev-util/ragel"
-
-ruby_add_bdepend "
- >=dev-ruby/rake-0.8.7
- >=dev-ruby/rake-compiler-0.7.1
- test? ( >=dev-ruby/diff-lcs-1.1.2 )"
-
-pkg_setup() {
- ruby-ng_pkg_setup
-
- # Export the VERBOSE variable to avoid remapping of stdout and
- # stderr, and that breaks because of bad interactions between
- # echoe, Ruby and Gentoo.
- export VERBOSE=1
-}
-
-RUBY_PATCHES=( ${P}-cve-2012-6684.patch )
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/d' Rakefile ${PN}.gemspec || die
- rm tasks/{release,gems,rspec}.rake || die
-}
-
-each_ruby_compile() {
- # We cannot run this manually easily, because Ragel re-generation
- # is a mess
- ${RUBY} -S rake compile || die "rake compile failed"
-}