summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-05-26 09:11:14 +0200
committerHans de Graaff <graaff@gentoo.org>2017-05-26 09:14:06 +0200
commitdd3eaf0769037e4bfe3f83acc7357f953d52ea8f (patch)
treeed57594d602df78bf21c985d1d28e6ef33f96cff /dev-ruby/rmagick
parentsys-kernel/vanilla-sources: Automated version bump to {4.4.70,4.9.30,4.11.3} ... (diff)
downloadgentoo-dd3eaf0769037e4bfe3f83acc7357f953d52ea8f.tar.gz
gentoo-dd3eaf0769037e4bfe3f83acc7357f953d52ea8f.tar.bz2
gentoo-dd3eaf0769037e4bfe3f83acc7357f953d52ea8f.zip
dev-ruby/rmagick: lock imagemagick to 6.x versions
RMagick only supports ImageMagick 6.x at the moment, bug 619684. Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/rmagick')
-rw-r--r--dev-ruby/rmagick/rmagick-2.13.4.ebuild6
-rw-r--r--dev-ruby/rmagick/rmagick-2.15.4.ebuild6
-rw-r--r--dev-ruby/rmagick/rmagick-2.16.0.ebuild4
3 files changed, 8 insertions, 8 deletions
diff --git a/dev-ruby/rmagick/rmagick-2.13.4.ebuild b/dev-ruby/rmagick/rmagick-2.13.4.ebuild
index dd8c1eba6bb..641aca209ca 100644
--- a/dev-ruby/rmagick/rmagick-2.13.4.ebuild
+++ b/dev-ruby/rmagick/rmagick-2.13.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -20,8 +20,8 @@ IUSE="doc"
# Since 2.13.3 rmagick now supports HDRI enabled, but with it enabled
# tests fail with segmentation faults.
-RDEPEND+=" >=media-gfx/imagemagick-6.4.9:=[-hdri]"
-DEPEND+=" >=media-gfx/imagemagick-6.4.9:=[-hdri]"
+RDEPEND+=" >=media-gfx/imagemagick-6.4.9:=[-hdri] =media-gfx/imagemagick-6*"
+DEPEND+=" >=media-gfx/imagemagick-6.4.9:=[-hdri] =media-gfx/imagemagick-6*"
all_ruby_prepare() {
# Avoid unused dependency on rake-compiler. This also avoids an
diff --git a/dev-ruby/rmagick/rmagick-2.15.4.ebuild b/dev-ruby/rmagick/rmagick-2.15.4.ebuild
index 07ce839d9c0..1856fd9f22c 100644
--- a/dev-ruby/rmagick/rmagick-2.15.4.ebuild
+++ b/dev-ruby/rmagick/rmagick-2.15.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -18,8 +18,8 @@ SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-macos"
IUSE="doc"
-RDEPEND+=" >=media-gfx/imagemagick-6.4.9:="
-DEPEND+=" >=media-gfx/imagemagick-6.4.9:=[jpeg]"
+RDEPEND+=" >=media-gfx/imagemagick-6.4.9:= =media-gfx/imagemagick-6*"
+DEPEND+=" >=media-gfx/imagemagick-6.4.9:=[jpeg] =media-gfx/imagemagick-6*"
ruby_add_bdepend "test? ( dev-ruby/rspec:3 )"
diff --git a/dev-ruby/rmagick/rmagick-2.16.0.ebuild b/dev-ruby/rmagick/rmagick-2.16.0.ebuild
index 861c52d6f49..2aaf1c16a1f 100644
--- a/dev-ruby/rmagick/rmagick-2.16.0.ebuild
+++ b/dev-ruby/rmagick/rmagick-2.16.0.ebuild
@@ -18,8 +18,8 @@ SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-macos"
IUSE="doc"
-RDEPEND+=" >=media-gfx/imagemagick-6.4.9:="
-DEPEND+=" >=media-gfx/imagemagick-6.4.9:=[jpeg]"
+RDEPEND+=" >=media-gfx/imagemagick-6.4.9:= =media-gfx/imagemagick-6*"
+DEPEND+=" >=media-gfx/imagemagick-6.4.9:=[jpeg] =media-gfx/imagemagick-6*"
ruby_add_bdepend "test? ( dev-ruby/rspec:3 )"