summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-09-14 10:35:42 +0200
committerJeroen Roovers <jer@gentoo.org>2019-09-14 10:40:39 +0200
commit6d4208982d86c95b77e68f9da8126f6417b1ef85 (patch)
treefd9f45a9fdde690f99f10db04a802453f326a953 /dev-ruby/rrdtool-bindings
parentpackage.mask: Last rite dev-python/*, m-needed, no-revdep, py3.6 (diff)
downloadgentoo-6d4208982d86c95b77e68f9da8126f6417b1ef85.tar.gz
gentoo-6d4208982d86c95b77e68f9da8126f6417b1ef85.tar.bz2
gentoo-6d4208982d86c95b77e68f9da8126f6417b1ef85.zip
dev-ruby/rrdtool-bindings: DEPEND on net-analyzer/rrdtool
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Bug: https://bugs.gentoo.org/690318 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'dev-ruby/rrdtool-bindings')
-rw-r--r--dev-ruby/rrdtool-bindings/rrdtool-bindings-1.6.0.ebuild1
-rw-r--r--dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.0.ebuild60
-rw-r--r--dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.1-r1.ebuild1
-rw-r--r--dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.1.ebuild59
-rw-r--r--dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.2.ebuild1
5 files changed, 3 insertions, 119 deletions
diff --git a/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.6.0.ebuild b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.6.0.ebuild
index 50bf714fd428..20f293c3ab7f 100644
--- a/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.6.0.ebuild
+++ b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.6.0.ebuild
@@ -29,6 +29,7 @@ RDEPEND="
~net-analyzer/rrdtool-${PV}[graph=]
"
DEPEND="
+ ${RDEPEND}
test? ( ~net-analyzer/rrdtool-${PV}[graph] )
"
diff --git a/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.0.ebuild b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.0.ebuild
deleted file mode 100644
index 1f8d1af39fcc..000000000000
--- a/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-RUBY_FAKEGEM_TASK_DOC=""
-inherit ruby-ng
-
-MY_P=${P/-bindings}
-MY_P=${MY_P/_/-}
-
-DESCRIPTION="Ruby bindings for rrdtool"
-HOMEPAGE="https://oss.oetiker.ch/rrdtool/"
-SRC_URI="${HOMEPAGE}pub/${MY_P}.tar.gz"
-RUBY_S="$MY_P"/bindings/ruby
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
-IUSE="graph test"
-REQUIRED_USE="test? ( graph )"
-
-# Block on older versions of rrdtool that install the bindings themselves.
-# requires rrd_xport which requires rrd_graph
-RDEPEND="
- ~net-analyzer/rrdtool-${PV}[graph=]
-"
-DEPEND="
- test? ( ~net-analyzer/rrdtool-${PV}[graph] )
-"
-
-RUBY_PATCHES=(
- "${FILESDIR}"/${PN}-1.4.8-graph-ruby.patch
-)
-
-each_ruby_configure() {
- rm ../../src/rrd_config.h || die
- touch ../../src/rrd_config.h || die
-
- ${RUBY} extconf.rb \
- --with-cflags="${CFLAGS} $(usex graph -DHAVE_RRD_GRAPH -UHAVE_RRD_GRAPH)" || die
-}
-
-each_ruby_compile() {
- emake V=1 ABS_TOP_SRCDIR="${PWD}/../.."
-}
-
-each_ruby_test() {
- if use graph; then
- ${RUBY} -I. test.rb || die
- fi
-}
-
-all_ruby_install() {
- dodoc CHANGES README
-}
-
-each_ruby_install() {
- DESTDIR=${D} emake install
-}
diff --git a/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.1-r1.ebuild b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.1-r1.ebuild
index 113be286f9b9..aa652bbfc94c 100644
--- a/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.1-r1.ebuild
+++ b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.1-r1.ebuild
@@ -26,6 +26,7 @@ RDEPEND="
~net-analyzer/rrdtool-${PV}[graph=]
"
DEPEND="
+ ${RDEPEND}
test? ( ~net-analyzer/rrdtool-${PV}[graph] )
"
diff --git a/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.1.ebuild b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.1.ebuild
deleted file mode 100644
index 4ed42759a6cb..000000000000
--- a/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-RUBY_FAKEGEM_TASK_DOC=""
-inherit ruby-ng
-
-MY_P=${P/-bindings}
-MY_P=${MY_P/_/-}
-
-DESCRIPTION="Ruby bindings for rrdtool"
-HOMEPAGE="https://oss.oetiker.ch/rrdtool/"
-SRC_URI="${HOMEPAGE}pub/${MY_P}.tar.gz"
-RUBY_S="$MY_P"/bindings/ruby
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
-IUSE="graph test"
-REQUIRED_USE="test? ( graph )"
-
-# Block on older versions of rrdtool that install the bindings themselves.
-# requires rrd_xport which requires rrd_graph
-RDEPEND="
- ~net-analyzer/rrdtool-${PV}[graph=]
-"
-DEPEND="
- test? ( ~net-analyzer/rrdtool-${PV}[graph] )
-"
-RUBY_PATCHES=(
- "${FILESDIR}"/${PN}-1.4.8-graph-ruby.patch
-)
-
-each_ruby_configure() {
- rm ../../src/rrd_config.h || die
- touch ../../src/rrd_config.h || die
-
- ${RUBY} extconf.rb \
- --with-cflags="${CFLAGS} $(usex graph -DHAVE_RRD_GRAPH -UHAVE_RRD_GRAPH)" || die
-}
-
-each_ruby_compile() {
- emake V=1 ABS_TOP_SRCDIR="${PWD}/../.."
-}
-
-each_ruby_test() {
- if use graph; then
- ${RUBY} -I. test.rb || die
- fi
-}
-
-all_ruby_install() {
- dodoc CHANGES README
-}
-
-each_ruby_install() {
- DESTDIR=${D} emake install
-}
diff --git a/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.2.ebuild b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.2.ebuild
index 113be286f9b9..aa652bbfc94c 100644
--- a/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.2.ebuild
+++ b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.7.2.ebuild
@@ -26,6 +26,7 @@ RDEPEND="
~net-analyzer/rrdtool-${PV}[graph=]
"
DEPEND="
+ ${RDEPEND}
test? ( ~net-analyzer/rrdtool-${PV}[graph] )
"