summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-10-31 08:58:23 +0100
committerHans de Graaff <graaff@gentoo.org>2020-10-31 08:59:21 +0100
commit41bdfec00c137754a93dd2abc78256654200597a (patch)
tree69b5ed5ab72d341a58a3d1740c8811b1cc38facf /dev-ruby/rspec-expectations
parentdev-ruby/rspec-support: add 3.9.4 (diff)
downloadgentoo-41bdfec00c137754a93dd2abc78256654200597a.tar.gz
gentoo-41bdfec00c137754a93dd2abc78256654200597a.tar.bz2
gentoo-41bdfec00c137754a93dd2abc78256654200597a.zip
dev-ruby/rspec-expectations: add 3.9.4
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rspec-expectations')
-rw-r--r--dev-ruby/rspec-expectations/Manifest1
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-3.9.4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/rspec-expectations/Manifest b/dev-ruby/rspec-expectations/Manifest
index e7185df186d2..dd17a6e881f4 100644
--- a/dev-ruby/rspec-expectations/Manifest
+++ b/dev-ruby/rspec-expectations/Manifest
@@ -2,3 +2,4 @@ DIST rspec-expectations-2.99.2-git.tgz 106884 BLAKE2B 5b31c8681306d5c688f62fc3fc
DIST rspec-expectations-3.8.4-git.tgz 200149 BLAKE2B 45fe4cdc4b032bb773ef0e7d3e9b75e6d14a6e8c1850ad6fd84991d85a61860730caa9f191aa9d1ce4e21c85dadd2c52bb69bd0a1454f5ab918dc1e563fc54f1 SHA512 0ecb16f11ccf19c02c40ce587f33846fb2241f1663dd87f012b9b782338c213362dac624c434dee6e00ad2cc7ec4a1cd0af7f2edf1a8e9ebb0a0dfb31cd244d8
DIST rspec-expectations-3.8.6-git.tgz 200343 BLAKE2B 9d668216c18716344e8c249086bcbf2b70e7c1a5a0d1f3a5328fe03752ef4ace6f5029219314016a4bb00ef482f440702a2adb7d9fe49392b5b1c6ec15f6a2e5 SHA512 9ded8de53127f63f2117f5ef64b6608b643586be498d8df24909366ce159a8bb95c9d8771633b777897f3e4ad3c9a12e3dfe62b2310513320b3d9656d24a120a
DIST rspec-expectations-3.9.1-git.tgz 203727 BLAKE2B 47db054658bdec43c252fd5ac155e7ca794d60ecf8c8b0d3c8e072cf05629153c9778ad618619e5cde5400c95a85c1520f2b9fc3824699af33805fa187549115 SHA512 23a453a46c3eb3bd3f2a39f48f62f05832cf559b570ba0e09235dd6299687254491bab50f5502fefe69dbdeefa09e9d8c5568bc77d0b6b658bb469e197e67572
+DIST rspec-expectations-3.9.4-git.tgz 206297 BLAKE2B c5dbebcf7b411c9cb5cd815dc06fb6f455e82181856661110f803b25f3910975f0676f3cf154e93fe771849363593e104e0f2dd298dfd3d8b1dd96a6ff991547 SHA512 bd025b89751b5b8d3c6bd61a90386fc05ca371e04247d93b29334bbb3eceb84bacea3f3846c20f08dbf53f174992b2dc0fe9f2bc449c4591188b5e428b1d8003
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-3.9.4.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-3.9.4.ebuild
new file mode 100644
index 000000000000..eff2dd3e6147
--- /dev/null
+++ b/dev-ruby/rspec-expectations/rspec-expectations-3.9.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-expectations"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+SUBVERSION="$(ver_cut 1-2)"
+
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.2.0 <dev-ruby/diff-lcs-2
+ =dev-ruby/rspec-support-${SUBVERSION}*"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-mocks-3.2.0:3
+ >=dev-ruby/rspec-support-3.5.0:3
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm -f Gemfile || die
+
+ # fix up the gemspecs
+ sed -i \
+ -e '/git ls/d' \
+ -e '/add_development_dependency/d' \
+ "${RUBY_FAKEGEM_GEMSPEC}" || die
+}